RTC not working Anymore

Some strange way, but RTC is not working anymore (since updating to Arduino 1.6.13 and Blynk 4.0??)
I have an Arduino running my lights, there RTC is working fine, but I cannot get RTC running on second Arduino Uno (same as the one running)
Even RTC example sketch is producing same error.

[0] Blynk v0.4.0 on Arduino Uno
[0] Getting IP…
[3515] IP:
[5001] Connecting to blynk-cloud.com:8442
[5740] Ready (ping: 37ms).
Current time: 0:0:13 1 1 1970
Current time: 0:0:23 1 1 1970
Current time: 0:0:33 1 1 1970
Current time: 0:0:43 1 1 1970
Current time: 0:0:53 1 1 1970
Current time: 0:1:3 1 1 1970
Current time: 0:1:13 1 1 1970
Current time: 0:1:23 1 1 1970
Current time: 0:1:33 1 1 1970
Current time: 0:1:43 1 1 1970

Solved by using timeNTP instead

Not exactly solved if you just used a different method.

The RTC widget will update ever 5min or so… I often see this happen as soon as I boot up my hardware but it comes right 5 min later.

You can set the interval to allow for faster syncing with “setSyncInterval(60);”. If the time is synced you can set it to use a bigger interval.

1 Like

Have you add widget to project?

Yes, RTC is perfectly working on a older project. When I tried/modified the project for running on NodeMCU, I ran into RTC problem. When I checked the old project on a spare Arduino Uno, I found out RTC was not working anymore in the old configuration.

Look like library issue. You can track progress here https://github.com/blynkkk/blynk-library/issues/244

Yes, that must be.
I will do some testing with order Arduino/Blynk combinations on a “clean” PC to determine when RTC stops working.
Will inform you.
Thank you so far.

I also had this problem, and solved it by moving the waiting for sync to occur out of setup(). It seems that Blynk.run() and timer.run() need to be activated in loop() before the time is updated from the Blynk cloud.

Wemos D1 R2 (ESP8266 WiFi)
Arduino IDE 1.6.7
Blynk v0.4.7

Closed as it is an older topic, issue appears non relevant with newer libraries.