RPI server, (same) RPI Client random errors (Using Blynk Python)

I have a rpi server and a Blynk client in the same rpi, for the past 2 months I had no problems but now the rpi client disconnects and in terminal it says
Error: Blynk server is offline, connection closed!
I’ve checked on the Blynk Server log files but I had no luck… the only thing I see is that the hardware joined not the reason of the disconnect…
Is there any other log files I can see?
In the server terminal there was no errors, and the other devices connected to the server were connected.
All the devices are connected to the same network and they are local.
Any thoughts? Thanks

EDIT: Forgot to say that the py script Isn’t the problem because the project was running correctly and with out any errors for 2 months and I haven’t changed anything.

What version local server?


Might want to update then… there have been 13 version changes since. Overtime, all three Blynk components (App, Library and Server) need to be kept fairly current with each other.

Well I tried to update the blynk client with the latest BlynkLib.py from GitHub and I get an error:

Traceback (most recent call last):
File “/xxxx/client.py”, line 10, in
blynk = BlynkLib.Blynk(BLYNK_AUTH, ‘xxxx’, xxxx)
TypeError: init() takes exactly 2 arguments (4 given)

any thoughts?

Search this forum for keywords like Python for varying methods of adjusting it for a Local Server IP… FYI I believe it is still an Alpha phase.

Well I agree but in August I created a topic about how to connect to a local server and you helped me figure it out and it worked…

Did this method change?

(I haven’t change my code since then and it worked(and works with the previous version of BlynkLib.py))

I don’t know, sorry. I haven’t worked with Blynk python… probably since back then :stuck_out_tongue:

were should I ask?

You just did with your post :smiley: … Now, aside from your own experimenting with different library and sketch syntax, you just need to wait until someone answers (if ever :wink: ). As stated Python is Beta and apparently not heavily used.

I also updated your title for better component recognition.

OK, I reloaded the latest Blynk Python library (0.1.3) and found my old test script in a backup… loaded it up and tried editing this command with my IP and port.

Works great for me :smiley: No longer any need to modify the library.

BLYNK_AUTH ='5fb55413762b400cbb979111b630b9af'
# Initialize Blynk
blynk = BlynkLib.Blynk(BLYNK_AUTH, '', 8080)

Well now I am worried, I downloaded the BlynkLib.py from this GitHub

and it says that the its the BlynkLib version 0.2.0.
is it a fake GitHub blynk page?

from the link you just gave me in the BlynkLib.py it says 2.0 but in the GitHub page it says 1.3