Registered user gets "User is not registered" in app

Pretty simple:

  1. Created account on Blynk website.
  2. Blynk sent confirmation email.
  3. I clicked on the email link to take me back to the Blynk website, and then clicked the link to finish the confirmation process.
  4. Have the Blynk app on my Android phone. Tried to login, but get the error “User is not registered”

What the … ?!

This is pretty basic. The email address I’m using is 100% correct, exactly as I have registered on Blynk.

Website and app are totally different.

Register new user IN THE APP if you want to use THE APP.

1 Like

Hi pfurrie,
if you have already done a registration on your mobile and you get this message, may you have a geo dns problem, which detailed in this article:
I had same issue, solved by follow this instructions.

Thanks for clearing that up.

Counter-intuitive system. I just want one Blynk account. Setting up on the website is the easiest, and should work across both platforms.

Also setup a Cayenne account (after running into the problem on the Blynk account). Cayenne worked as one would expect: create an account on the website, and it works perfectly on the app.

@pfurrie well, that’s because you are the first person for many months who registered in web before app :grin:.

That isn’t a reason for why two accounts would be preferred over one.

Sure it is not. However we have hundreds of other features for Blynk app in our Roadmap. I rather implement something cool there and when it ready will come back to accounts feature. I believe many Blynkers think the same way.