Redirecting and connecting/disconnecting messages

I also have same problem although I have just one Uno on my circuit. I get Redirecting to message and then blynk keeps giving message og “Connected” and then “Disconnected” after every 10-15 seconds.

@asad1 I’ve moved your post to a topic of it’s own, as it appears to be substantially different to the topic that you posted in.

The “Redirecting to…” message isn’t an error, it’s just for information.

Blynk has three cloud servers around the world, located in New York, Frankfurt and Singapore and each has its own IP address.
Your Blynk account/project only lives on one of these servers and when you try to connect using your ISP’s DNS server attempts top resolve to an IP address. Normally this is the IP address of the geographically closest server, and for you that will probably be the Frankfurt server.
However, your project actually lives on the New Your server, so when the Frankfurt server receives the connection request it cant find your project, so it searches the other two servers for it. When it finds it on the New York server it redirects your connection request to the IP address of that server - in this case.

I’m not sure why your Blynk account/project lives on the New York server. Possibly because you were in a different country when you created the account, or because your mobile ISP has some unusual DNS settings or maybe your government has some requirement for them to operate in this way.

It would be useful to see your serial output, with timestamps turned on, to determine if the connections are actually being made then dropped, or whether you are misinterpreting the information that you are seeing. it would also be useful to see the ping times that are shown when (if) a connection is actually being made.

It is also possible that the sketch you are using is badly written. If it has a long delay in the void loop then this will cause a disconnection from the Blynk server after around 10 seconds, so this may be the cause of the problem. It’s impossible to say without seeing your code.
When you do post your code, ensure that you put triple backticks at the beginning and end of it so that it displays correctly.
Triple backticks kook like this:
copy and paste them if necessary.

If you are running one of the Blynk sample sketches, and/or f you aren’t seeing a ping result in the serial monitor, then it may be that your ISP is blocking port 80

You can instruct the Blynk library to use the New Your server directly, and to use port 8080 rather than port 80, but the details of how to do that will depend on your existing code and on what is appearing in your serial monitor.


1 Like

Problem solved by user using this method…


my apologies Pete and to forum members. I am a total newbie so end up posting message in wrong place.

hello… i have problem with redirecting… currently I am in the UK the app worked in Kuwait but I think now the server number needs to be changed … what is the server number as I can connect to the latest version to blynk. (80, 8080, 8442, 8443) didn’t work…

Are you using blynk IOT or legacy ?

blynk IOT

Okay, update the library to the latest version which is 1.0.1 instead of 0.6.1

i used the same codes in my country with this code and it worked but when I came to UK its not

Blynk.begin(auth, wifi, ssid, pass, "", 80);

I recommend using

Blynk.begin(auth, ssid, pass);

Without specifying a server name or port.
You can post your whole sketch so we can take a look at it.

1 Like

Please edit your post and add triple backticks ( ``` ) before and after your whole sketch.

1 Like

When using blynk, you should keep your void loop as clean as possible to avoid any issues in the future.
The ideal blynk void loop should look like this

void loop() 

More details here

1 Like

If you want to force a connection to the Singapore server then you could use:

Blynk.begin(auth, wifi, ssid, pass, "", 80);

but you should certainly be using version 1.0.1 of the Blynk library and sort-out your void loop as @John93 suggested.


1 Like