Reconfigure button is not showing for newly added devices

• Hardware model + communication type. — ESP32 + WIFI
• Smartphone OS (iOS or Android) + version ---- ANDROID 1.18.0
• Blynk server or local server — BLYNK
• Blynk Library version ---- 1.3.2

Blynk Team,

Reconfigure button is not showing in actions for new/unconfigured old devices.
Please resolve.

Hello @Seth_MSR1. As far as I remember it is correct for new devices. @BlynkAndroidDev please confirm

The Reconfigure button is visible only for devices added through device provisioning. If your new/old devices have been created manually - they would not have such an option.

That’s different behaviour to the iOS app then.
In iOS the reconfigure option is available for all of my devices, and the majority of them have been created manually and are used via Node-Red.


1 Like

Blynk team we heavily rely on you for our business, please don’t put these barriers in adding new devices. We are layman kind of person don’t understand your advance features.

Please keep simple features intact.

And resolve this ASAP.

We will not allow this option for any devices. But I believe we can enable this option to be always visible for developer users, even if their device hasn’t been added via provisioning. Would this suit your case?

Probably, we can improve checks for devices that may have this option, by checking templates connection type as well - we will discuss this internally.

Atleast first reconfigure should be allowed for devloper. After it users can do it if there admin allow it. Please enable this option right now.

And what’s the provisioning process please share details.

What different provisioning I am doing from this manual.

IoT Device Provisioning

Does adding a new device from template is a manual process?
If yes then what should I do?
All of my newly added devices doesn’t shows reconfigure button to devloper itself.
Then whom have rights to configure it.
@BlynkAndroidDev @Oleksii-QA

I need a solution today as I have to deploy devices at client end.

@Seth_MSR @Seth_MSR1 why do you have two logins to this forum?

Please tell me which of these two logins you’d like to use going forward and I’ll deactivate the other one.


Kindly deactivate @Seth_MSR1

I’m assuming that the correct process is…

  1. Create Template
  2. Create Edgent sketch
  3. Add the two lines of firmware configuration from the template to the Edgent sketch
  4. In the app choose “+ Add Device”, select the device and provision it with WiFi Credentials
  5. if you wish to reconfigure the device with new WiFi credentials choose “Reconfigure Device”


1 Like

'Atleast first reconfigure should be allowed for devloper. After it users can do it if there admin allow it. Please enable this option right now." -

it will work in such a way with the next update, but I don’t think it will be available as fast as you want, review time in the Play Store has recently increased to several days at least. It will probably be available in 1.19.1 version in a week, as we are currently awaiting 1.19.0 review and can’t reupload the new build due to this.

If you can recreate your devices via ‘Add Device’ flow as described above by Pete - it will solve your issue. If you sketches on those devices support ‘reconfigure’ than they are already provisioned with edgent sketch, so removal of existing devices and reading them by add device flow should work fine.