Rc.local Startup Problem on RasPi


I’m trying to get the blynk-client.js to run during startup on my Raspberry Pi using the rc.local file. Below is my rc.local system log shows this error. Any idea how to solve this “getaddrinfo EAI_AGAIN” error? Thanks!

  • node /usr/local/lib/node_modules/blynk-library/bin/blynk-client.js
    OnOff mode
    Connecting to: blynk-cloud.com 8441
    throw er; // Unhandled ‘error’ event
    Error: getaddrinfo EAI_AGAIN
    at Object.exports._errnoException (util.js:746:11)
    at errnoException (dns.js:49:15)
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:94:26)

This doesn’t sound like a Blynk related issue… Try GOOGLING your error… I did and found these… well, many more, but three examples are enough :wink:

All which basically came down to a network connectivity and/or proxy issue. Have you done anything to your router settings that might explain this?

Thanks! I think you are correct. I created a shell script for now that I manually execute. I’ll dig into this more. I’m suspecting that when my rc.local is called on startup, the my RasPi is not yet on network…service not fully running. Everything is fine when I call my shell script to start up my code. Thanks again.

@RasPiBurg try installing forever and forever-service