BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Raspi3 run client on local sever

I have created a local server on a raspberry pi 3 It is up and running I am able to send myself a email with the token. now I am trying to get the client running and i have followed http://help.blynk.cc/how-to-connect-different-hardware-with-blynk/raspberry-pi/how-to-install-nodejs-library-on-linux
It is all going good until Run default Blynk client (replace YourAuthToken):

export PATH=$PATH:/opt/nodejs/bin/
unset NODE_PATH
blynk-client YourAuthToken

that wants to connect to the cloud server I need the command/s for connecting to a local server. I have tried
export PATH=$PATH:/opt/nodejs/bin/
unset NODE_PATH
blynk-server=192.168.0.24 -port=8555 -token=

Any help would be appreciated

So, does it give any error … ?

The format for using a local server is:

./blynk --server=xxx.xxx.xxx.xxx --token=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

See also https://github.com/vshymanskyy/blynk-library-js/blob/master/examples/nodejs/client-tcp-local.js

When I use sudo ./blynk --server=192.168.9.24 --port=8555 --token=AuthToken It will try to start blynk and say
[5001] Connecting to 192.168.0.24:8555
[5001] Can’t connect to 192.168.0.24
[10002] Connecting to 192.168.0.24:8555
[10002] Can’t connect to 192.168.0.24
[15003] Connecting to 192.168.0.24:8555
[15003] Can’t connect to 192.168.0.24

Why are you using port 8555?

1 Like

Is your server 192.168.0.24 or 192.168.9.24 as you show both on your last post?

the ip is 192.168.0.24 when I typed a 9 it was a typo going form different screens and not being able to get the exact command i typed in the terminal window

The reason I had the port in the command was I copied it from http://www.raspberry-pi-geek.com/Archive/2015/12/Blynk-for-Raspberry-Pi/(offset)/2

./blynk --server=xxx.xxx.xxx.xxx --token=xx worked
Now to get it autorun

Well, normal port is 8441 or 8442, but may be unnecessary if you are connecting to a Local Server from inside your network.

Read up on the official Server and RPi directions:

http://help.blynk.cc/how-to-connect-different-hardware-with-blynk/raspberry-pi/blynk-and-raspberry-pi-tips-tricks

http://help.blynk.cc/how-to-connect-different-hardware-with-blynk

That is a VERY old web page in the whole scheme of IOT and Blynk. Don’t mess around with ports unless you are a networking god. By not stating the port it will use the current port determined by Blynk and all should be fine providing you don’t have the port allocated to anything else.

Presumably you have the Blynk local server starting automatically.

Do a Google search for the forever-service. Without it the client will try to start before the server and fail.

thanks i will

Hi guys !

I don’t know i i can wake up this post…

But i’ve same problem than @qballizhere i think the command change from 3 years… I’m looking for the command for put token form app to raspberry ( wich is client + server )

@CharlesTestas please keep this discussion to one topic…

Pete.