Rasperry Pi Zero Standalone Server only working when wifi dongle connected via a USB hub

Hi everyone. I am very thankful to Blynk community as I just completed my first Raspberry Pi Zero local standalone server, which is running fine. I used USB Hub for setting up Blynk server. (for Bluetooth Keyboard and Wifi Dongle). Server is working OK, but whenever I remove USB hub and connect only Wifi Dongle with Pi Zero usbOTG cable there is no AP available. rebooted again with USB Hub with Wifi dongle and its working OK. Please tell me what I am doing wrong?. Thanks

Sounds more like a RPi networking question for an RPi forum.

The Blynk server does not control the network, it just works with whatever is there… but perhaps it is expecting to work with the network interface it was started with, not a secondary one. Have you tried rebooting or at very least restarting the Local Server after swapping networks?

Thanks for repIy.I checked with a display connected. when wifi dongle connected direct to zero via USBOTG there is no AP available. (I cant use keyboard or mouse to check icon properties)
But with USB HUB my AP “RaspberryPiZero” is available and working and when click on icon it is showing:-
wlan0:Associated with “RaspberryPiZero”(My AP)

Then I connected 2nd wifi dongle to HUB and its showing
wlan0:Associated with “RaspberryPiZero”(My AP)
wlan1:Associated with SVITZER “My Home wifi”

We really are not that type of troubleshooting forum… we do Blynk stuff here :wink:

However, if your router keeps changing your devices IP, then it is no wonder your App and devices can’t find the server.

G :eyes: gle around for ways, if possible, to keep the same MAC address, despite the changing networking devices (and have your router maintain a static IP based on the MAC).

Or G :eyes: gle some other way to have the RPi maintain a static IP regardless of networking interface.

Thank you. thats give me ideas. thanks again.

[This is an educated guess since I don’t have an RPi]

During the initial setup (using the hub), your network (kernel?) settings may have associated the WiFi-dongle with a BUS and DEVICE ID that becomes different when you plug it in directly.

I think the standard RPi Debian has the commands lsusb (List USB devices) and/or usb-devices (Print USB device details). If you run these cmd with your dongle connected thru the hub and then again without, you should get different BUS and DEV ID.

Can’t offer you any solution, but worth mentioning for your further troubleshooting :slight_smile:

Thanks. I can check this with USB hub connected. but without Hub I can’t access anything as there is no AP avaiable when wifi dongle directly connected to PI zero.

pi@raspberrypi:~ $ lsusb
Bus 001 Device 004: ID 1997:2433
Bus 001 Device 007: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 002: ID 0a05:7211 Unknown Manufacturer hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@raspberrypi:~ $


As @Gunner has said, this isn’t a Blynk issue.

Is the hub powered by the Pi or an external PSU?

Its power by Pi Zero.