Raspberry pi zero won't connect to browser admin

I am new to Blynk. With the features it has, I decided to try it out for my travel trailer. Some of the locations I go to, there is no wifi/cell service. So I decided to try a local server on a pi zero. After hours of reading and hours of watching videos over and over again, I was able to get it to work, sort of. So now to the issue. I can not log into the Blynk browser admin page. I am using Windows and chrome and Edge. I have tried and tried the raspberry’s ip address 192.#.#.#:9433/admin and it does not work. But on the app, it connects. So I don’t understand why I can connect on my phone’s app, but I can’t connect to the browsers admin page with my computer. I have read several post here, but I could not find the answer. Do I need access to the browser admin page to make it work…
Thank you, is your localhost, i.e. it points back to the computer you are using (your Windows machine). Please note that it should be two zeros (0.0.) in the middle, not zero one (0.1.) if you want to connect to your localhost.

You need to use https like this https://192.#.#.#:9433/admin

Check your server.properties file and make sure your allowed to connect from your current IP. By default it only accept connections from localhost I think. Look for this line: allowed.administrator.ips=

Thank you.
How do I check the server properties file?

The easiest way is to enable SSH on your Pi then run WinSCP and connect to the Pi’s IP on port 22.

Your server.properties file (if it exists) will be in the same location as your Blynk serber.jar file (unless you’re specifying a different location when you start the server)

If you don’t have a server.properties file then create one as described here…


Thank you for the info.
I tried to connect again to the browser with a different computer and it worked. I used http://192.#.#.#:9443/admin (my ip for the pi). I don’t understand why it would not work yesterday, used same ip address, the only difference, is a different computer.

Back again. Have a question about connecting to the Blynk browser. Only the computer that I mentioned before will connect. I can not connect with my phone browser, tablet browser, or other computer. Also when I put in the address on the working computer it takes me directly to my page with my info. The over devices, like my phone takes me to a Google question page. I would think that I could use any device with a browser, that is on the same wifi that the local Blynk server is on. Also I tried my first blynk D1 mini, to connect to this local server and on the app, I get that it is offline. Not sure if code( copied/checked from multiple sites/ videos) or pi/ Blynk local server. I thought this might be an easier option for my travel trailer to use local, but for me its not turning out like that.

As mentioned previously, the range of IP addresses that can connect is controlled by an entry in the server.properties file. We cant help you unless you provide information about what entries you have in your server.properties file.

Note also that any edits made to the server.properties file (or other configuration files) via the admin console are not saved.

What server connection settings did you use in your sketch, and what connection failure message did you get in your Wemos’s serial monitor?


I figured out that my server sketch was wrong and got it working, I did not have 8080, put it back in, worked. In one of the videos I looked at, they removed it.
I installed WinSCP and connected to the pi, but don’t know where to look for the file. I opened the Blynk folder and there were other sub-folders; backup, clone, deleted, blynk email, and my email for Blynk. Not sure where to go to look for the server.properties (maybe I don’t have it). Not sure where the Blynk serber.jar file is either, I clicked on all the folders and did not see that file. WinSCP_pi

I thought it might be the Server-0.41.13-java8.jar file, but when I click on it, it starts a download to a temporary file, not sure if I should do that, so cancelled.

What command do you use when you start the Blynk server?


Sorry for my ignorance. I am not sure what you are asking. If you mean which command I put in crontab -e, it is …
@reboot java -jar /home/pi/server-0.41.13-java8.jar -dataFolder /home/pi/Blynk &

That’s fine, you aren’t specifying a different location for your server properties file.
If you were then it would look more like this:

java -jar server-0.41.13-java8.jar -dataFolder /home/pi/Blynk -serverConfig /home/pi/someFolder/server.properties

So, this means that you don’t have a server.proprrties file.
I’d recommend creating one as described here…