Raspberry pi with server and arduino via USB

I have a question.
Can I connect an Arduino Mega to a Raspberry Pi 3 with the installed server via USB.

Now my Arduino Mega works via the w5100 extend board. But it has problems with connecting frequently. So I have to reboot the Arduino time by time and use watchdog.

In theory, if you use the Linux USB script blynk-ser.sh and point to the same IP as is assigned to the RPI, it should work… I think the concept has been mentioned here before, but I don’t know if anyone has tried it yet.

Read On Linux and Mac in this document:


Thank you for your reply.
But before reconstruction my “smart home” I would like to be sure that
./blynk-ser.sh -c /dev/ttyACM0 -b 9600 -s localhost -p 8442
-like command is acceptable.
Could anyone test it?

At the moment I am also looking for an answer. Anybody have the answer?

@DufeRob and @kikilich Arduino with USB via the RPi certainly works and it’s very stable.

Up to now most of my tests have been with Blynk’s cloud server and just using the script without any parameters is generally fine. It will search for the correct com port which is useful as RPi reboots don’t always give identical devices ACM0 might become ACM1 etc.

It will also reconnect every 3 seconds if there is a disconnection.

It was a long time ago when I used the local server in this way but I have been looking at it again recently.
You can enter the baud rate, server address and port number in the script so again you should be able to call the function without any parameters.

The only issue I have is regarding SSL and TCP. For Blynk’s cloud server it is set as SSL but local servers will often be basic TCP. I tried changing the ports around in the script but I believe there is another flag that needs setting for basic TCP in place of SSL.

Could @vshymanskyy or @Dmitriy please indicate what the script change or command line syntax is for local server with TCP over USB?