BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Raspberry Pi 3 as server

hi.

my knowledge in the Linux world limited , i have tried to run a local server on RPI 3 running latest RASPBIAN JESSIE WITH PIXEL.

i have followed the provided guide to start Blynk server on Boot , but no success.
i have repeated the steps more than once and make sure that it’s OK , am i missing something or there is a difference because of the latest update of rasbian?

thanks

What is going wrong? I’d be happy to help you, but need some more details :slight_smile:

@scropion86 I find the crontab fix more reliable than the init.d edit.

the server run fine , but the run after boot is not happening

Put it in init.d. It’s the only good solution and widely accepted. Be sure to use a delay in your startup script. If you put it in the correct init.d, it should be very stable. Crontab is more for timed things (like simpletimer). Init.d is the place to put startup scripts.

Can you indicate what you did to make it run at start up? Maybe you followed a certain webpage? I can take a look at it :slight_smile:

Yes, like on bootup and appears to be consistent across different derivatives of Unix, unlike init.d.

init.d has eveolved on the Debian platform and works really well. Usually it’s some sort of weird script error or putting things on the wrong runlevel, bad software or such which screws up the process.

That’s why I recommend the simple crontab route unless you are a Unix guru.

I have init.d on a Cloud server but I couldn’t get my Pi to accept it.

Weird. Anyway, crontab is of course possible and if it works, it works :slight_smile:

1 Like

i have tried to edit rc.local and add java -jar /home/pi/server-0.18.3.jar -dataFolder /home/pi/Blynk &
but i am getting access denied and i logged in using the root user

edit : i have changed it using other editor with root access but after restart not working

That’s not really the right procedure. First off, it’s alway recommended to make a startup script. There is one on the forum here (which I provided). You can place that in your Blynk directory and add the script to init.d. You cannot simply add a line to rc.local. You have to tell it to add the script.

This documentation should work: https://debian-administration.org/article/28/Making_scripts_run_at_boot_time_with_Debian

i didn’t test that but now it is working using crontab :slight_smile:

1 raspberry pi 3 running Blynk server allows many registered accounts