Proxy authentication over USB Blynk connection

So i have a little project that uses a PC (i need it to be connected to a PC) for internet connection, i want to leave my project in my educational institution. The problem is that the institution’s internet have a firewall that needs a proxy login and passaword (aka proxy authentication) just like this image :

How can i authenticate my connection over USB? (the PC is a Windows)

There are a couple of programs out there which can handle that for you. It’s kind of important to know which kind of authorization is required. If there is an MS Proxy in place (yuck!!!) it will require NTLM authentication. You can google for ntlm proxy and a lot of different options will come up. In most cases it requires you to install a bit of software on the PC which will handle the proxy authentication for clients who do not speak “proxy”. Usually this problem only occurs when using NTML authentication though.

Thanks, i will check with the institution’s TI and them i will tell you what type it is.

Anyway, I’m assuming things don’t work right now, is that correct? Because if you connect via USB your PC should handle the connection and proxy requests and not the Arduino. Did you try connecting?

Not yet, but i know that the server Will only allow connections outside the local group via my credentials. I Hope it Works without any aditional software, but probaly the proxy Will be a problem.

So, i have tried and this is the error that i got:

it works perfect at home, but at the institution that happens, i asked for the IT to open port 8442 but i’m not sure if that is the problem

Well, it bounces somewhere. Can you do a simple telnet to that server on that specific port? I fear, judging from the error number, it’s an ISA or TMG firewall doing the proxy and they will probably not allow SSL traffic on anything other than port 443 (which is quit standard … ).

The IT security specialist from the institution contacted me and said:

Translating, He openned the 8442 port in squid proxy for authenticated connections, i hope that Proxifier works like you said. So, you think it will work? I will only be able to test in 6 days.

Squid, that’s good news! It’ll probably will work with something like Proxifier. At least Squid is a decent piece of software, so I anticipate it won’t give you too much trouble.

As a last resort you can always setup a local Blynk server on the campus network.

So i finally tested it and unfortunately it didn’t worked. According to the IT guy proxifier can’t work with squid so i tried a different aproach, i tried to authenticate my connection in the blynk-ser.bat script like this:

Normal Script:

@echo off
setlocal EnableDelayedExpansion

REM === Edit these lines to match your need ===

set COMM_BAUD=9600
set SERV_PORT=8442

New Script:

@echo off
setlocal EnableDelayedExpansion

REM === Edit these lines to match your need ===

set COMM_BAUD=9600

set HTTP_PROXY=http://proxyip:proxyport
set HTTP_PROXY=http://login:password@proxyip:proxyport
set HTTPS_PROXY=https://proxyip:proxyport
set HTTPS_PROXY=https://login:password@proxyip:proxyport

set SERV_PORT=8442

but for some reason it still didn’t worked, giving the same error as mentioned above, local server is not an option because the ideia of the project is to remote control a highschool physics experiment over the internet.

I really don’t know what else to try, maybe @Dmitriy could help me out :sob:

I don’t know how the variables in the last batch script are going to help, but aren’t you supposed to setup proxifier with some rules to allow internet access? Can you post what you configured there? I’m an IT guy to but sometimes I just say “can’t make it happen” because I’m too lazy or don’t want to figure out how something works, no offense to my unseen IT colleague of course. I don’t see why proxifier wouldn’t work with squid. I happen to know a little bit about squid and it’s fairly simple to setup and maintain. Maybe you could figure out what the IT guy configured, I’d be happy to take a look at it.

However, for the purpose of demonstrating the power of Blynk it’s OK to use a local server. In the end, all that the Internet is, is a very BIG IP network, just like the local LAN. So if it works over the lan, it’ll work over the internet too.

Anyway, from a regular PC, can you do a telnet to 8442 ? It should break the connection fairly soon because you don’t do the handshake, if it takes longer than 10s you know there is some networking error.

If you do use your own computer on the campus network it may be possible for me to use TeamViewer and try and help you out that way, but let’s go on a bit from here now.

Blynk works over TCP/SSL/TLS and not HTTP/S. So how do you expect to work it via http proxy?

But the hardware side should work over http, right?


nvmind, USB connection will do SSL …

Yes. May work over http/s.


telnet to 8442 wasn’t working, i was trying to solve it, but without success

i tried a bunch of configurations on proxifier, and there was a giant error message. i wasn’t able to save the error log, but the only configuration that the local network did not rejected was this:

i could connect to the AP but without internet.

So if blynk works over TCP/SSL/TLS is there a way to authenticate like a tried to do in the batch file?

i use a computer that the campus gave me to do the project, but i have no admin in that PC. I will bring my own next time and if you can i would love to get some help from you on teamviewer. I’m a noob in networks :sweat_smile: and i really strugle with this.

Well, I’d be happy to schedule some “tech-time” to see if we can sort out your issue. If you want to set something up, please send me a PM so we can make a Blynk-Date :heart_eyes:

Because it should be :slight_smile:

gez, if that was the mistake i will be so mad with myself :joy:

I was thinking, it may indeed be the wrong port from the script…

Try this: NEED HELP: arduino via serial USB over Raspberry Pi 3