BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Provisioning last stage

Hi,

I am trying to use the dynamic provision with the preview app.
The first two stages of the provisioning are executed straight forward but the third stage (checking) is failing. After that I can’t see any more the “Our Product” SSID going live since the device think it is registered already but in reality it is not.
I am not sure what the third stage is but I see it happening on multiple devices.
I am using the current version of Blynk library.
Any help will be appreciated.
Thanks
Sharon

You should check what is seen in Serial Monitor. The answer is most likely there

Hi,

Thanks for you reply.

Thats what I see in the Serial monitor.

connection failed Due to host or HTTPS

I am not sure what is the checking stage do during the provisioning.

Thanks
Sharon

Hi,

I have a device that was provisioned in another network, I want to move it to my network, the device will not go into provisioning since it was already provisioned and it is looking for the initial network.
How can I Re-Provision a device like that?

Thanks
Sharon

I’ve merged these two topics together, as they are about the same basic subject.

Pete.

We need a full print of the serial monitor. From getting to AP mode to error.

Also, send logs to developer

1 Like

Thanks Pavel, will work on this.

Do you have also an answer to my seconds issue (re-provision) that for some reason was merged into this issue.

In the settings.h tab of the provisioning program, there should be a pin defined for the the BOARD_BUTTON_PIN This is the pin/button for resetting the WiFi credentials. It will depend on the type of board you selected in Template Tab.

Thanks for the reply this is very helpful. I am using an 8266 D1 Mini board, the only button is the reset button, I need to check if the user can read it.

Let me know if you had any experience with this board.

Thanks
Sharon

I think I figured the issue, I still need to do more testing.
In the ESP8266 (WeMos D1 R1) I am having issues with all the version after 2.5.0 of the board configuration. Please note that they changed the way IRAM and the Flash are working, I am not sure if Blynk had a chance to test this.
Thanks
Sharon

Hi,

After checking the schematics of the WeMos D1(https://escapequotes.net/esp8266-wemos-d1-mini-pins-and-diagram/) I see that the Reset as expected is connected to RST pin, I guess this button can’t function as a WiFi reseting. Any other ideas?

I’m guessing that the idea is for you to connect your own button to the specified pin (and GND or 3v3 depending on what the sketch is expecting) that you can use to trigger reprovisioning.

I doubt very much if the version of the Wemos D1 Mini has any impact on the process, although the version of the ESP Core may have.

Pete.

Hi,

I was referring to the ESP core library, I tried different version and experienced the issues with version 2.5.0 and above, after some digging I understood that the major differences and I believe the way the IRAM and the flash is used can cause issues with any type of WiFi connection.

For the WeMos esp8266 you would need to make sure that you selected the custom board in the template tab.

/*************************************************************
  This is a DEMO. You can use it only for development and testing.
  You should open Setting.h and modify General options.

  If you would like to add these features to your product,
  please contact Blynk for Businesses:

                   http://www.blynk.io/

 *************************************************************/

//#define USE_SPARKFUN_BLYNK_BOARD    // Uncomment the board you are using
//#define USE_NODE_MCU_BOARD        // Comment out the boards you are not using
//#define USE_WITTY_CLOUD_BOARD
#define USE_CUSTOM_BOARD          // For all other ESP8266-based boards -
                                    // see "Custom board configuration" in Settings.h

#define APP_DEBUG        // Comment this out to disable debug prints

#define BLYNK_PRINT Serial

#include "BlynkProvisioning.h"

void setup() {
  delay(500);
  Serial.begin(115200);

  BlynkProvisioning.begin();

}

void loop() {
  // This handles the network and cloud connection
  BlynkProvisioning.run();

}

and then in the settings.h tab you would define the pin you want your wifi reset button connected to (due note this IS NOT the reset button. It is a button you would wire between the defined GPIO and ground). Its default is GPIO 0.

#if defined(USE_CUSTOM_BOARD)

  // Custom board configuration
  #define BOARD_BUTTON_PIN            0                     // Pin where user button is attached
  #define BOARD_BUTTON_ACTIVE_LOW     true                  // true if button is "active-low"

  #define BOARD_LED_PIN               2                     // Set LED pin - if you have a single-color LED attached
  //#define BOARD_LED_PIN_R           15                    // Set R,G,B pins - if your LED is PWM RGB 
  //#define BOARD_LED_PIN_G           12
  //#define BOARD_LED_PIN_B           13
  //#define BOARD_LED_PIN_WS2812      4                     // Set if your LED is WS2812 RGB
  #define BOARD_LED_INVERSE           false                 // true if LED is common anode, false if common cathode
  #define BOARD_LED_BRIGHTNESS        64                    // 0..255 brightness control

I solved this with a timer that runs once disconnected, it changes the mode of the device so that it can then be reprovisioned or WiFi reconfigured. Let me know if you want details of this solution.

Thanks for the input.

Are you saying you are getting into provision mode every time you are disconnected?

Thanks
Sharon