BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Program doesn't run anymore because of "Redirecting to 45.55.96.156:80"

Hello,

I built a project in the US which was working fine. The components were Arduino Mega+ESP8266-01. I purchased to good chunk of energy to put together all necessary widgets on the app. I tested everything and app worked flawlessly with my project. I shipped it to a different country only to realize that at the very beginning when it connects to internet it says “Redirecting to 45.55.96.156:80” and the whole program stops at the startup. I read couple of posts online and it seems like this may be a GeoDNS issue, but it was repeatedly mentioned that this issue was fixed in 2017. I have no idea how to fix it and couldn’t really wrap my head around the explanations online as mostly people were using local servers verses blynk server. Could someone please point me in the right direction?

Blynk has several servers around the world. Maybe you can’t connect to an American server from within the coverage area of ​​another server?
What country, if not a secret?

It is in Iraq. I don’t necessarily want to connect to a US server, but i believe it is trying to do that because the project is built in the US. Is there a way to make it connect to the regional Blynk server?

If you have a project with an account, then it is most likely on an American server and the local server does not have your account and project.
I think you can do it through the ip,but by changing the code a little.
You will need to use blynk.begin() functions to connect to an alternate private server.

Blynk.begin(auth, SSID, pass, IPAddress(American IP), 8080);

Un_ka thank you for the direction. Forgive my lack of understanding in the IP world, how do I find out what is the US IP? if the equpment is not in the US, is it possible to get the US IP now? Or is it as simple as the “45.55.96.156”?

Try this, but separated by commas. If this does not work, then you will need to find out the ip of the American server.
I do not know him because I am in the largest country in the world. The ip that I found for the local server- 139.59.206.133

Thank you so much. Your direction coupled with another post helped me fix the problem. But now when I change the state of couple buttons on the app quickly it says that the
Packet too big: 11081 and disconnects.
I have a re connection code in my code so it eventually reconnected but it is a disruption to the whole sequence when that happens. Does this have anything to do with the fact that I’m directing it to a US server? Is there a way to have the “program” sit in a Blynk server that is directly correlated to that region?

45.55.96.146 Is the IP address of the New York server.

When you created the project from your phone, you could be using either your home WiFi or your mobile data provider, or you may have been connected to a different WiFi network. Each ISP could be using different DNS servers, so blynk-cloud.com could be resolving to a different Blynk cloud server.
I guess (and forgive my ignorance if I’m wrong) that in countries like yours some ISPs may choose or be instructed to block access to some content from certain countries.

Blynk has two other cloud servers, one in Frankfurt (IP address 139.59.206.133) and the other in Singapore (IP address 188.166.206.43). The Frankfurt server will be geographically closest to you.

In theory, it should be possible to force the app to connect to the Frankfurt server by logging-out then clicking this icon:

Then entering the Frankfurt IP address:

If this is successful then you’ll need to create your project again, and you’ll have a new Auth code that you’ll need to use in your sketch.
You could also specify the Frankfurt IP address in your sketch. It may also be worth specifying port 8080 rather than 80, as this is less likely to be blocked by your ISP.

Pete.

Thank you Pete. I appreciate the detailed response. You are right, I pinged blynk-clound.com and singapore server poped up. I tried to force it to connect to the Singapore server (188.166.206.43) through this code:

Blynk.config(wifi, auth, server, port);
  if (Blynk.connectWiFi(ssid, pass)) {
    Blynk.connect();
  }

but it automatically redirects again to 45.55.96.146.
The question that I still have is: does the reason for disconnect (packet too big) has to do with the redirecting of the project from singapore server to NY server? becasue when i tested it here in the US, it was working fine.

It shouldn’t cause this problem, the redirection normally works fine.
My guess is that the issue is caused by one of two things…

  1. long ping times to the NY server that are causing timing issues
  2. some packet shaping or filtering that is being done by your ISP.

The ‘packet too big’ message seems to occur when communication between the device and the server get out of sync.
My guess is that your Iranian ISP is doing some sort of content filtering and the Blynk data packets are being corrupted by this process, but that’s just a guess.

Pete.

Thank you Pete. I think my best bet is to recreate the project in a different account from the region instead from the US as that would generate a new token that could directly ping the server in the region. Hopefully that eliminate the first issue that you outlined above, if that is a part of the cause.
This begs the question, do the energy tokens that I purchased on my US account go to waste? or Is there a way to transfer them to the new account?

I have no idea I’m afraid.
Easy way is to try it and see.

Pete.

Thank you so much for your help sir. You can close this topic.

1 Like

I’ve marked the topic as solved, but you(and others) can still post here.
It would be useful if you let us know the outcome of this.

Pete.