BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Problems with Arduino Uno Wifi Rev2

Hi Pete,
actually, i have the same issue with Arduino Uno Wifi Rev2. and got the blow massage error,

[Unformatted compiler error message removed by moderator]

Your support is highly appreciated
Wael

@Wael_Wahba_Battisha Please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your compiler error message so that it displays correctly.
Triple backticks look like this:
```

Copy and paste these if you can’t find the correct symbol on your keyboard.

Pete.

1 Like

Hi pete,

the below error message as follows,

Arduino: 1.8.19 (Windows Store 1.8.57.0) (Windows 10), Board: "Arduino Uno WiFi Rev2, ATMEGA328"





















In file included from C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkApi.h:36:0,

                 from C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/BlynkApiArduino.h:14,

                 from C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Adapters/BlynkWiFiCommon.h:24,

                 from C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/BlynkSimpleWifi.h:24,

                 from C:\Users\wael1\Documents\Arduino\IOT\IOT.ino:31:

C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkParam.h: In member function 'long long int BlynkParam::iterator::asLongLong() const':

C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkParam.h:48:50: error: 'atoll' was not declared in this scope

         long long   asLongLong() const  { return atoll(ptr); }

                                                  ^~~~~

C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkParam.h:48:50: note: suggested alternative: 'atol'

         long long   asLongLong() const  { return atoll(ptr); }

                                                  ^~~~~

                                                  atol

C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkParam.h: In member function 'long long int BlynkParam::asLongLong() const':

C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkParam.h:89:46: error: 'atoll' was not declared in this scope

     long long   asLongLong() const  { return atoll(buff); }

                                              ^~~~~

C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkParam.h:89:46: note: suggested alternative: 'atol'

     long long   asLongLong() const  { return atoll(buff); }

                                              ^~~~~

                                              atol

exit status 1

Error compiling for board Arduino Uno WiFi Rev2.



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

So you haven’t edited the BlynkParam.h library file as described in the link I provided in post #4 of this topic?

Pete.

Thanks for your effort to support me,
I would like to know how to perform this modification. I’m not an expert in dealing with this.
Are there any changes that should be made to the Blynk IOT and or the code below, the libraries below are correct for wifi rev2.
thanks,
Wael

[Unformatted code removed by moderator]

@Wael_Wahba_Battisha if you persist in posting unformatted code to the forum then your account will be suspended.

You need to find the BlynkParam.h file on your computer (part of the Blynk library files) and edit it as described in the link I provided.
Once you’ve done this, re-compile your sketch an - if you’ve done the change correctly these error messages will disappear.

Pete.

the code was submitted from Blynk examples library,
[Blynk Example Browser]
(Blynk Example Browser).
Wael

How is that relevant?

Pete.

Hi Pete,
i implement as you recommendation in post #4
return atoll(ptr); and change them to return atol(ptr);
then: return atoll(buff); to return atol(buff);
and run program,
i got
~
Error compiling for board Arduino Uno Wi-Fi Rev2.
~
I tried the code for using Wi-Fi Rev2 with Blynk IOT

Would you like to take a look at this, please?

What is the full compiler message (don’t forget the triple backticks).

Pete.

Hi Pete,
I got the below compiler message, an error marked with ~~~

In file included from C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkApi.h:36:0,
                 from C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk.h:14,
                 from C:\Users\wael1\Documents\Arduino\IOT\IOT.ino:15:
C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkParam.h: In member function 'long long int BlynkParam::asLongLong() const':
C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkParam.h:89:51: error: 'ptr' was not declared in this scope
     long long   asLongLong() const  { return atol(ptr); }
                                                   ^~~
C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkParam.h:89:51: note: suggested alternative: 'puts'
     long long   asLongLong() const  { return atol(ptr); }
                                                   ^~~
                                                   puts
Multiple libraries were found for "Blynk.h"
 Used: C:\Users\wael1\Documents\Arduino\libraries\Blynk
 Not used: C:\Users\wael1\Documents\Arduino\libraries\Blynk_For_Chinese-0.5.9

BR
Wael

You seem to have screwed-up the BlynkParam.h when you edited it. I’d suggest that you go and get a fresh copy from here:

then re-read the link I provided and carefully make the changes that it specifies.

I’d also remove this library too…

as it doesn’t work with Blynk IoT and could cause you problems in future.

Pete.

1 Like

Hi Pete,

i perform as you mentioned above. then compiled, there is no error.
but when go to upload to card, i got this massage:

[Unformatted compiler error message deleted by moderator]

your recommendation
BR
Wael

Pete.

I do it.

In file included from C:\Users\wael1\Documents\Arduino\IOT\IOT.ino:16:0:
C:\Users\wael1\Documents\Arduino\libraries\Blynk\src/Blynk.h:15:2: warning: #warning "Please include a board-specific header file, instead of Blynk.h (see examples)" [-Wcpp]
 #warning "Please include a board-specific header file, instead of Blynk.h (see examples)"
  ^~~~~~~

C:\Users\wael1\AppData\Local\Arduino15\packages\arduino\hardware\megaavr\1.8.7\cores\arduino\UNO_compat.cpp:20:2: warning: #warning "ATMEGA328 registers emulation is enabled. You may encounter some speed issue. Please consider to disable it in the Tools menu" [-Wcpp]
 #warning "ATMEGA328 registers emulation is enabled. You may encounter some speed issue. Please consider to disable it in the Tools menu"
  ^~~~~~~

BR

Why is this so different from the compiler error message you posted without the required triple backticks?

Pete.

@Wael_Wahba_Battisha I’ve split all of your posts from the original topic, so that it keeps that original topic clean and useable for other forum members.

Pete.

This while compiling by Arduino IDE 2.0.0 rc9.4
The first compiler error message by Arduino Genuino.
BR
Wael

If you want help with this issue you really need to start helping yourself with some sensible communication.

Pete.

I think you also need that. You don’t have to thank me.