Problema connessione

Buonasera l app blynk se sono connesso ad una wifi funziona tutto senza problemi mentre se sono fuori non si connette come mai?

You can’t use the app without internet connection.

Fuori ho la connessione internet standard no wifi e non dovrebbe funzionare ugualmente?

Yes, it should work over mobile internet.
What exactly does your app say when you attempt to connect when attached to GSM ?

Have you tried restarting your phone?


No non ho provato a riavviare il telefono
L app dopo un po’ che prova a connettersi mi dice che il server non si riesce a collegare

Ho riavviato il telefono ma con il mobile non si connette

Post a screenshot of the app message, and share details of whether you are using iOS or Android and what app version you are using.


Uso android

Okay, when you created this topic you chose “Blynk 2.0” as your category, which has confused us.

You are actually running Blynk Legacy with a local server.

The reason you can’t connect from outside of your own network is that you haven’t set-up port forwarding on your router, and if you don’t have a static public IP address you haven’t set-up a DDNS service along with a DDNS updater.

If you search the forum for topics about port forwarding and DDNS with local server you’ll find the information you need.


Hai ragione scusami ho sbagliato dove inserire il topic

Can someone help me please? I had a local server on my Synology storage for several years and it worked to my full satisfaction. I manage the whole house with it and use it only for myself. I restarted the server today after the new year and now I can’t connect to the local server from the app. What should I do please? I saw somewhere that it was supposed to end on 31.12.2022, is that true?

The legacy cloud servers were decommissioned at the beginning of January, but this has no effect on local servers.
Are you using the legacy app (which has now been removed from the app/play stores)?


I don’t see, I didn’t change anything at all, I just restarted the server

I think I have an older app yes. But I can’t even connect with a browser to port 9443. And all this only after restarting the server

Has the Synology device’s IP address changed?
Can you access data stored on the NAS.


The IP address is still the same, I connect to the server via SSH normally and I see that the blynk server version 0.41.16 is running in the background

I don’t insist on having my own local server. But when I was writing the home management app, I used it because it seemed like a better development idea at the time. But now I don’t know how to transfer all the data to your server and still have a paid service. Because without a functioning server I can’t even heat the house :wink:

I’d start by rebooting everything - router, NAS, PC, Phone, any WAP’ and Ethernet switches, and all of your devices.
If you run a DDNS service then ensure that it’s updated and check that your port forwarding rules are correct.
Take a look at the server logs to look for clues about any server issues etc.
After that it’s really down to you to figure-out your own networking issues to get to the bottom of the problem - one of the drawbacks of being your server and network admin person.

As far as migrating to Blynk IoT (and by the way I’m nothing to do with Blynk), then it would probably be best to set-up a free account and do a bit of tinkering to get familiar with the differences. Take a read of this for some links to tutorials, and for a summary of the main differences between Legacy and IoT…

If you want to get more specific then I’d recommend starting a new topic of your own.