Problem wtih Blynk Local server

i have seacrh bu don’t find information for my problem.

I have test blynk with cloud server , the test is ok my wemos D1 is working.

I have install local server on raspberry pi

the server is ok , it s possible for me to connect my android application to rasp server.
i see this message on blynk.log : " blyn-app (android…) joined

but on my android application, my wemos is “wasnt online yet”

With your Android app logged-in to the local server, have you created a project and used the auth code for that project in your Wemos D1 sketch?
Also, have you changes your Wemos sketch so that it connects to your local server rather than the Blynk cloud server?

I’m guessing that you’re using a cloud server auth code on your Wemos at the moment, and still trying to connect to the cloud server.

What does the serial output from your Wemos show - it should give you some clues.



my code for the wemos use a new auth code and i have change cloud server by my ip server

see :

  Download latest Blynk library here:

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials:
    Sketch generator: 
    Blynk community:  
    Follow us:        

  Blynk library is licensed under MIT license
  This example code is in public domain.


  You’ll need:
   - Blynk App (download from AppStore or Google Play)
   - WeMos D1 board
   - Decide how to connect to Blynk
     (USB, Ethernet, Wi-Fi, Bluetooth, ...)

  There is a bunch of great example sketches included to show you how to get
  started. Think of them as LEGO bricks  and combine them as you wish.
  For example, take the Ethernet Shield sketch and combine it with the
  Servo example, or choose a USB sketch and add a code from SendData

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "aa036AAAAAAAA1fffb768e";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "broAAAAAssier";
char pass[] = "AAAAAAAAAAA";

void setup()
  // Debug console

  pinMode(D8,OUTPUT); // ajouter les sortie D utilisé
  digitalWrite(D1,LOW); // niveau automotique en cas de coupure low=0 high=1

  //Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "", 80);
  **Blynk.begin(auth, ssid, pass, IPAddress(192,168,0,11), 80);**

void loop()
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!

i see a default on the log fil off blynk server :

WARN - ATTENTION. Server certificate paths (cert : ‘/etc/letsencrypt/live/’, key : ‘/etc/letsencrypt/live/’) not valid. Using embedded server certs and one way ssl. This is not secure. Please replace it with your own certs

1 Like

I’ve edited your code so that it displays correctly. In future you should do this:



ok thank’s, do you have an idea for my problem please

I’m not a local server user, but I do know that the output from your serial monitor would help those that are to understand more about what is happening when your device tries to connect.

Posting that between backtics makes it display correctly as well :grinning:


Default hardware port for Local Server is 8080, not juist 80.

ok thank’s
I corrected my mistake
reprogram with 8080
but still the same problem

can you give us the serial log?

1 Like

Third time lucky???



08:52:48.652 INFO - Using data dir '/home/pi/Blynk'
08:52:50.813 INFO - Region : local. Host :
08:52:52.363 INFO - Initializing gmail smtp mail transport. Username : SMTP host :
08:52:52.458 INFO - Reports : 0
08:52:52.463 INFO - Didn't find Let's Encrypt certificates.
08:52:52.463 WARN - You didn't specified '' or '' properties in file. Automatic certificate generation is turned off. Please specify above properties for automatic certificates retrieval.
08:52:52.473 WARN - ATTENTION. Server certificate paths (cert : '/etc/letsencrypt/live/', key : '/etc/letsencrypt/live/') not valid. Using embedded server certs and one way ssl. This is not secure. Please replace it with your own certs.
08:52:53.681 INFO - HTTP API and WebSockets server listening at 8080 port.
08:52:53.687 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
08:52:53.689 INFO - Mqtt hardware server listening at 8440 port.
08:53:24.957 INFO - Blynk-app (android-22702) joined.

That looks like a server log rather than the serial output from your Wemos D1.


I swung and missed.

To get your serial log, using the arduino ide, you’ll want to go here.

and then, this is the log we all should be looking at to help troubleshoot.

1 Like


i do this :

this log confirm my wemos D1 is connect to my server

but in the blynk app is not online

It confirms that it’s trying to connect, but hasn’t yet been successful.
The first screenful of data that’s printed to the serial monitor when the device first boots should contain more info. That’s what I was hoping you’d share.


J’ai redémarer mon tel android et tout fonctionne.

merci pour votre aide

1 Like