BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Problem with MEGA + ESP - cmd error appears periodically

#1

Hello. I have exactly the same problem with MEGA + ESP - cmd error appears periodically. You have not managed to solve this problem, find the reason?

0 Likes

"Cmd error" debug Serial problem
#2

Please don’t tack a “me too” post onto other topic… particularly one almost a year old :wink:

Supply details on the exact hardware you are using (that other topic was using a Robotdyn board with integrated ESP) and your code that causes the issue.

Please properly format the code asr required in the Welcome Topic.

0 Likes

#3

Hello… The problem was my Arduino board… I think the problem was occured because many uploads of code… I know there’s a number of times which you can erase and write in a memory…

I brought a new board and uploaded the same code and it worked…

Sometimes it would upload in a defective board and sometimes doesn’t…

I recommend you to test your code in another board first and see if you still gets the same error…

0 Likes

#4

So I will probably do … Thank you!

0 Likes

#5

Ok, if it works, tell me

0 Likes

#6

Hello.
I used the ATmega2560 + ESP8266 Robotdyn board to communicate with the BLYNK server.
Periodically (every few minutes) the controller is disconnected from the server, then it reconnects itself, and so constantly.
Here is my code:

#define BLYNK_DEBUG
#define BLYNK_PRINT Serial
#include <ESP8266_Lib.h>

#include <BlynkSimpleShieldEsp8266.h>

char auth[] = "xxxxxxxxxxxxxxxxxx";
char ssid[] = "xxxxxxxx";
char pass[] = "xxxxxxx";
#define EspSerial
#define ESP8266_BAUD

ESP8266 wifi(&Serial3);
void setup()
{
  Serial.begin(9600);

  Serial3.begin(115200);
  delay(10);

  Blynk.begin(auth, wifi, ssid, pass);
 }
void loop()
{
Blynk.run();
}

In the com port monitor, I see a systematic error: cmd error.cmd%20error
Version libraries BLYNK: v0.6.1;
ESP8266 firmware: NON-OS SDK V2.1.0.
Thanks for the help!

0 Likes

#7

Maybe someone will tell me what the cmd error means … To at least understand where to look for the cause … :thinking:

0 Likes

#8

I don’t know, but it seems like it is a message, presented when using Debug mode, that something caused a disconnection, buffer overflow or timeout, etc??.. as referenced in the BlynkProtocol.h file in your libraries folder, so I suppose you can try to read all that code and figure it out.

image

0 Likes

#9

Thank you for participating in my problem!
I will try to find out …

0 Likes

#10

Just a guess, but you may be looking at a networking issue and Blynk is just reacting to it?

0 Likes