Problem with ESP-01 as wifi for Arduino pro mini

I’m new to Blynk. Downloaded the library and trying to use the examples with no success. I keep getting the following error message on compilation and can’t figure out how to fix it.

C:\Users\David\Documents\Arduino\ProMini_ESP8266_Blynk_01\ProMini_ESP8266_Blynk_01.ino:31:29: fatal error: ESP8266_HardSer.h: No such file or directory

#include <ESP8266_HardSer.h>

It looks like you need to include the library. In the Arduino IDE go to “Sketch” then “Include Library” then select the library. It first has to be installed in your Documents\Arduino\Libraries folder. Here’s a better guide on the process:

You need to go to and download: .

This folder contains ESP8266_HardSer.h

Thanks. Making progress but…

ProMini_ESP8266_Blynk_01:37: error: ‘Serial1’ was not declared in this scope

#define EspSerial Serial1

By the way, that was extremely confusing. I went to Blynk github and downloaded the library. Why was that not the latest release?

Instead of Serial1, try just Serial

C:\Users\David\Documents\Arduino\libraries\Blynk/BlynkSimpleShieldEsp8266.h:14:2: error: #error Sorry, we changed things a little bit. Please check new examples for ESP8266. This is easy to fix :slight_smile:

#error Sorry, we changed things a little bit. Please check new examples for ESP8266. This is easy to fix :slight_smile:

Nolmath, this error message was received trying to compile the example in your Instructable Connect to Blynk using ESP8266 as Arduino Uno wifi shield (Mac only).

Is it an issue with libraries? I downloaded them again and still get error messages. And where are these so called new example?

You need to change BlynkSimpleShieldEsp8266.h to BlynkSimpleShieldEsp8266_HardSer.h in your arduino code

This new .h file was introduced after the instructable was made. I haven’t gotten around to updating it yet

1 Like

No, that didn’t work either. Even worse. The list of errors is a mile long. I don’t think I’ve been able to get ONE single Blynk example to compile except using an esp-12 standalone. Even with that I get an error message about the esp8266 disconnecting. I have installed the latest libraries and using the latest examples (as far as I can tell) and still have compile errors. I have never had this much trouble. Has anybody really done this successfully? And willing to share code that works?

Hmmmm… That should have worked. Are you sure you are putting the libraries in the right folder?

Well, I’m feeling really stupid. Needed to change

#include <ESP8266.h> to #include <ESP8266_HardSer.h>

#include <BlynkSimpleShieldEsp8266.h> to #include <BlynkSimpleShieldEsp8266_HardSer.h>

Glad you got it figured out! :slight_smile:

Thanks for your help

1 Like

After countless tries I cannot connect to Blynk server. All I get is the following:

[18] Blynk v0.3.1
[520] Connecting to LaHacienda
[1538] Failed to disable Echo

Any ideas?

Did you check your wires? I usually get this when I mix up Tx and Rx …

I’ve checked, double checked, triple checked wiring. Tried multiple ESPs. Reinstalled firmware on several of them. I’ve got a separate power supply. With a capacitor. Every thing I’ve read about I’ve tried. I’ve tried every thing I can think to try. It has to be something so simple that I’m just overlooking it but for the life of me I can’t figure it out. I’ve used ESPs before on other projects months ago and they worked but now I can’t get them to work with Blynk.

What firmware are you running?

The one recommended. 1.0.0 v0.22

Maybe you can try the latest Blynk library? I think there is a 0.3.2 beta somewhere which fixes some ESP issues.