Problem with datastream widget in Android version 1.15.0(178) from 26/01/2024

After updating my Android Blynk version to 1.15.0(178) I notice that inputting a string in a datastream widget does not work anymore. I’ll try to explain although I am not an expert: instead of sending the string to the application, I can now only add a CR to the string, but it does not get sent to the application anymore. Did anything change? (I did not change the application and it worked fine for months before). Please help.

What type of widget are you using?

What type of datastream are you using (String, Integer, Float)?


Hi Pete, I use a virtual pin declared as a string and the widget is a text input. see screenshots:

Thanks for looking into this, Regards,



Can you open datastreams tab of that device in Console, what value for that datastream it shows and what value app shows.

Hi, the value in the datastreams tab of that device shows the last value entered when it still worked. It does not get updated with a new value. When I enter text in the app it shows the string entered there , but I can only push CR after that text and then the field shows a blank line because it just did a CR and the text entered is pushed to the next line (invisible in the one line input field). When I delete the last entered character (the CR) the text entered before shows up again. I am not sure, but I think the Android keyboard did show something else than the CR (green arrow bottom right of the screen) to actually send the entered text to the blynk cloud. See screen below:

Hope this helps.
PS: It is also possible that there was another line on the screen on top of the keyboard to actually enter the input which now disappeared, I don’t remember and I can’t check anymore. Sorry about that :wink:

Got it; the issue is about no ‘Send’/‘Done’ action on the keyboard, correct? Will fix it soon.

yes, sorry for my clumsy description :wink:

1 Like

Hi, just installed the update from Jan 30th. It works like before!
Thanks for the quick fix.

1 Like