BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Problem with Connection to Blink-Cloud

Hi. I need help with the connection between Nodemcu ESP8266 and Blynk.
For more than two months I have been working with a sketch that worked well until yesterday. It is a Nodemcu ESP8266 connected to Blynk and working with an app on my smartphone. Since yesterday it is impossible to connect with Blynk. So, I got suspicious about my code. Because of this, I flash the ESP8266 with an example provided by the Library. This is ESP8266_Standalone. The library version is V0.6.1.
After connecting to the Wifi network, the phase to connect to Blynk begins, but this does not happen. Attached you can see the messages:
Connecting to Claudio
[251554] Connected to WiFi
[251554] IP: 169.254.179.34
[251554]
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
/
//_, /////_
/
__/ v0.6.1 on ESP8266

[251638] Connecting to blynk-cloud.com:80
[256639] Connecting to blynk-cloud.com:80
[261640] Connecting to blynk-cloud.com:80
[266641] Connecting to blynk-cloud.com:80
[271642] Connecting to blynk-cloud.com:80

And forever and ever.
I was looking a solution here and tested a lot of recomendations, but anyone worked.
Can someone help me?
Thanks in advance,
Claudio

Did you get a new token and put that in the example?
Can you ping the blynk server?
What example are you using?
Did you update the hardware OTA or by USB?
What country are you in?
Have you tried it with a local server?

This isn’t a valid IP address within your home network.
Try resetting your router and any wireless access points/repeaters you may have.

Pete.

Hi Gyromike. Thanks for your interest in help me.
And yes, I tried with a diferente token. When I ping the Blynk-Cloud it respond, but not when I do a telnet. I am from Argentina.
Sorry but I don´t know how to update the hardware and why it´s necesary?
The Wifi net is Ok, but the only modification I do was put this ESP as fixed IP and not managed as DHCP,
I reset the router, but is the same.
Thanks

How did you configure the static IP? Did you configure the gateway and DNS settings as well?
What does your serial monitor show with these new settings?
Do you have anything connected to your board other than the USB cable?

Pete.

Thanks Peter. I just reset the router and changed the fixed IP for DHCP managed.
And the IP changed to 169.168.0.143, but the issue still continues.

Our messages was crossed in time.
The device at this moment is only connected with the usb cable and nothing more.
The change was an intend to test, but as you say was wrong.
The serial monitor shows the messages that I attached in my first post.
Regards

What IP address range is your home network using?

Is your router set-up with a limited DCHP pool size, or is your router configured to only accept whitelisted devices?

Until you get an IP address that is in the same range that’s used by your home network then you’ll never make any progress with connecting to Blynk.

Pete.