BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Problem with BlynkGSM_Manager and TTGO TCALL

hello,
I have a sketch, that works on a TTGO TCALL esp 32 and connected to the blynk server with wifi. No Problems. All fine.
Now I want to use the TTGO_TCALL_GSM example and I want to connected the blynk server with gprs.
I´ve loaded sketch to my esp32 and connected the esp over the 192.168.4.1 to enter my network ssid and password, the gprs apn, user and password and enter the projekt auth token. Push save and restart the esp, like the discription here: GitHub - khoih-prog/BlynkGSM_Manager: Simple GSM shield Manager for Blynk and ESP32 / ESP8266 boards, with or without SSL, configuration data saved in SPIFFS / EEPROM. This library enables user to include both Blynk GSM/GPRS and WiFi libraries in one sketch, run both WiFi and GSM/GPRS simultaneously, or select one to use at runtime after reboot.

But the esp din´t connect to my network and / or I can´t connect with the blynk app. Not over wifi and not with gsm.
This is the monitoring that I get:

00:49:12.892 -> ets Jun  8 2016 00:22:57
00:49:12.938 -> 
00:49:12.938 -> rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
00:49:12.938 -> configsip: 0, SPIWP:0xee
00:49:12.938 -> clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
00:49:12.938 -> mode:DIO, clock div:1
00:49:12.938 -> load:0x3fff0018,len:4
00:49:12.938 -> load:0x3fff001c,len:1216
00:49:12.938 -> ho 0 tail 12 room 4
00:49:12.938 -> load:0x40078000,len:10944
00:49:12.938 -> load:0x40080400,len:6388
00:49:12.938 -> entry 0x400806b4
00:49:13.400 -> 
00:49:13.400 -> Start TTGO_TCALL_GSM (Simultaneous WiFi+GSM) using LittleFS on TTGO_T7_V14_Mini32
00:49:13.400 -> BlynkGSM_Manager v1.2.0
00:49:13.400 -> ESP_DoubleResetDetector v1.1.1
00:49:13.400 -> Set GSM module baud rate
00:49:16.397 -> Use WiFi to connect Blynk
00:49:16.444 -> LittleFS Flag read = 0xD0D04321
00:49:16.444 -> No doubleResetDetected
00:49:16.444 -> Saving config file...
00:49:16.444 -> Saving config file OK
00:49:16.536 -> [3365] Hostname=TTGO-TCALL-GSM
00:49:16.583 -> [3398] LoadCfgFile 
00:49:16.583 -> [3402] OK
00:49:16.583 -> [3402] CCSum=0x3c99,RCSum=0x3c99
00:49:16.583 -> [3414] LoadCredFile 
00:49:16.583 -> [3418] OK
00:49:16.583 -> [3418] CrCCsum=0xc30,CrRCsum=0xc30
00:49:16.628 -> [3428] LoadCPFile 
00:49:16.628 -> [3432] OK
00:49:16.628 -> [3432] bg:Stay forever in CP:No ConfigDat
00:49:16.628 -> [3443] SaveCPFile 
00:49:16.628 -> [3446] OK
00:49:16.628 -> [3458] SaveBkUpCPFile 
00:49:16.628 -> [3462] OK
00:49:17.505 -> [4323] 
00:49:17.505 -> stConf:SSID=TestPortal-ESP32,PW=TestPortalPass
00:49:17.505 -> [4323] IP=192.168.4.1,ch=3
00:49:17.643 -> [4468] LoadCfgFile 
00:49:17.643 -> [4474] OK
00:49:17.643 -> [4474] CCSum=0x3c99,RCSum=0x3c99
00:49:17.690 -> [4490] LoadCredFile 
00:49:17.690 -> [4496] OK
00:49:17.690 -> [4496] CrCCsum=0xc30,CrRCsum=0xc30
00:49:17.690 -> gprs apn = Internet.telekom
00:49:17.690 -> DRD/MRD, Forced Config Portal or No valid stored apn. Must run only WiFi to Open config portal
00:49:18.751 -> FF
00:49:18.796 -> Your stored Credentials :
00:49:18.796 -> MQTT Server = blank
00:49:18.796 -> Port = blank
00:49:18.796 -> MQTT UserName = blank
00:49:18.796 -> MQTT PWD = blank
00:49:18.796 -> Subs Topics = blank
00:49:18.796 -> Pubs Topics = blank
00:49:23.179 -> Stop doubleResetDetecting
00:49:23.179 -> Saving config file...
00:49:23.224 -> Saving config file OK
00:50:18.763 -> FFFFFFFF

It dosn´t connected to my ssid or to my apn. What´s wrong? Do I have to enter the adress of the blynk cloud server? Where could I find this?

I’ve tested with the same TTGO_T7_V14_Mini32 and be sure the library is working OK.
You have to read the doc carefully and correctly follow the instructions there.
I’m afraid it’s very difficult for anybody to know what you’re doing wrong and help you.
Important hint

bg:Stay forever in CP:No ConfigDat
Start TTGO_TCALL_GSM (Simultaneous WiFi+GSM) using LittleFS on TTGO_T7_V14_Mini32
BlynkGSM_Manager v1.2.0
ESP_DoubleResetDetector v1.1.1
Set GSM module baud rate
Use WiFi to connect Blynk
LittleFS Flag read = 0xD0D04321
No doubleResetDetected
Saving config file...
Saving config file OK
[3384] Hostname=TTGO-TCALL-GSM
[3415] LoadCfgFile 
[3420] OK
[3421] CCSum=0x547d,RCSum=0x547d
[3435] LoadCredFile 
[3441] OK
[3441] CrCCsum=0x1cda,CrRCsum=0x1cda
[3441] Hdr=ESP32_GSM_WFM,BrdName=TTGO_TCALL
[3441] SSID=HueNet1,PW=password
[3441] SSID1=HueNet1,PW1=password
[3444] APN=rogers-core-appl1.apn,User=wapuser1
[3448] PW=wap,PIN=12345678
[3450] Server=account.duckdns.org,WiFi_Token=token,GSM_Token=token
[3461] Server1=192.168.2.32,WiFi_Token1=token,GSM_Token1=token
[3471] Port=8080
[3472] ======= End Config Data =======
[3487] LoadCPFile 
[3492] OK
[3492] Connecting MultiWifi...
[15816] WiFi connected after time: 1
[15816] SSID:HueNet1,RSSI=-34
[15816] Channel:2,IP address:192.168.2.204
[15817] bg: WiFi OK. Try Blynk
[15818] 
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v1.0.0 on ESP32

[15831] Connecting to account.duckdns.org:8080
[15951] Ready (ping: 8ms).
[16019] Connected to Blynk Server = account.duckdns.org, Token = token
[16019] bg: WiFi+Blynk OK
gprs apn = rogers-core-appl1.apn
[16022] 
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v1.0.0 on ESP32

[16091] InitModem
[16113] Con2Network
[16124] Network:Rogers Wireless
[16124] Conn2 rogers-core-appl1.apn
[24955] GPRSConOK
[24965] BlynkArduinoClient.connect: Connecting to account.duckdns.org:8080
[25609] Ready (ping: 315ms).
Your stored Credentials :
MQTT Server = mqtt.duckdns.org
Port = 1883
MQTT UserName = yourName
MQTT PWD = yourPWD
Subs Topics = SubsTopic1
Pubs Topics = PubsTopic1
BGBGBGBGBGBGBGBGBGBG BGBGBGBGBGBGBGBGBGBG BGBGBGBGBGBGBGBGBGBG BGBGBGBGBGBGBGBGBGBG

hello khoih,
thanks for your response.
I´ve nothing changed on the example sketch, except to enter the ssid and password of my network for testing and yes, I thing the library is working, but the question is what is my error. :slight_smile:
You can see that I have absolutely different monitoring as yours. Is the somewhere a diffrent instruction, for dummys? Because I can´t find my error… :smiley:

Just follows the steps in So How It works.

If you still can’t make it working, you have to post in details the steps you did, along with the terminal outputs and/or screen shots (certainly after modifying the secrets : password, token, etc.). In this way, we at least can have some basic info to help you.

ok, I think I find the error. I don´t have cleard the blank fields and have not entered anything new.
Now it works.

But how can I call now the configuration mode to change something? The default ip address no longer works and with the new IP of my network I can´t call the configuration mode. Do I have to turn the wifi off or is there another possibility here?

Check the Features

  • Multi or Double DetectDetector feature to force Config Portal when multi or double reset is detected within predetermined time, default 10s.

I suggest you at least read /scan thru the README, whenever you have any issue. Don’t expect somebody to have time to help you in every simple step. I’m out now.

Good Luck,