BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Problem with Blynk.begin , code won't runing

Blynk library 0.6.1
Android
Arduino

Previously I tried to successfully connect it even can be controlled from Android to Arduino.

Before the last error I did was Arduino using the battery, when I re-uploaded via the laptop something happened.

Then I tried removing blynk.begin, it succeeded to run the program.

scheme:
I use Bluetooth connected to a laptop, then use a virtual serial port, run local server and client to connect COM from Bluetooth to local server. Controlled by Android from WiFi.

I use the scheme to fulfill my college assignments. thanks.


#include <BlynkSimpleStream.h>


char auth[] = "W9KxUhtSLkGGAyxYmiDImNjGC0DKiKmF";


void setup()
{
  Serial.begin(9600);
  Blynk.begin(auth, Serial);
  pinMode(13, OUTPUT);
}

void loop()
{
  Blynk.run();
  digitalWrite(13, HIGH);
  delay(3000);
  digitalWrite(13, LOW);
  delay(3000);
}


Please go to the “Sketch Builder” above select your board and your connection method. It will have the needed libraries and the correct format. Take note of the note in the void loop comments!! //No delays…

I think you’re on your own trying to figure-out issues with that approach!

Pete.