BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Problem reading 433mhz signals

arduino
esp8266
nonblynkrelated
#1

Hello again

So I’m trying to use Blynk to open/close a garage door. The system works with 433.92 mhz signals. My plan is to link a transmitter to a NodeMCU and put it next to the garage receiver, using it as a wireless remote. The main problem is I can’t read any signals from the garage remote. I’m using the rc_switch library with one of the examples code. I can upload the sketch to the board but nothing would show up in the serial monitor after pressing buttons on the remote. I’ll post a few pictures below with my circuit and the parts I’m using.

image

Here is the code I’m using:

#include <RCSwitch.h>

RCSwitch mySwitch = RCSwitch();

void setup() {
  Serial.begin(9600);
  mySwitch.enableReceive(D3);
}

void loop() {
  if (mySwitch.available()) {
    output(mySwitch.getReceivedValue(), mySwitch.getReceivedBitlength(), mySwitch.getReceivedDelay(), mySwitch.getReceivedRawdata(),mySwitch.getReceivedProtocol());
    mySwitch.resetAvailable();
  }
}

I’ve also tried using other pins, but still no result.

Also, here’s some info about the garage door/remote

Thank you

//I also tried changin the VCC pin from Vin to 3V3.

0 Likes

#2

You’re using the RC Switch ReceiveDemo_Advanced example.
I don’t really understand what the “output” part of the RC Switch command does. Personally always use the ReceiveDemo_Simple example and this is much more logical as it users serial print commands.

I also use this library:

The hardware you’re using is okay, but I prefer the type that has a crystal on the board rather than a tuning coil.
Like this:

However, the receiver you’re using at the moment should be fine for testing. If you still can’t get anything out of RC switch you may need to try connecting your 433 Rx to the sound card of your PC and analyse the codes that you’re getting.
This thread on the MySensors forum explains more about it, along with a post from me about how I managed to decode the 433 signals for my blinds:

Pete.

1 Like

#3

Thank you for your reply @PeteKnight

The code I’ve posted is indeed the example sketch ReceiveDemo_Advanced, but I have also tried using ReceiveDemo_Simple without getting results.Maybe I’m not getting the pins right? I’ve read a few tutorials about receiving RF signals and most of them seem to use pins such as 0,1,2,3,etc instead of D#. However, I have also tried the following line in my code “mySwitch.enableReceive(15);” (thinking that 15=GPIO15=D8 on the nodemcu, correct me if I’m wrong) but still no luck. Does the reicever need an external power source? I have the Vcc/GND pin connected to the Vin/GND pins of the NodeMCU, would that be a problem? I have also tried using a 9V battery to power it, having a common GND with the NodeMCU…same problem. I should add that I used 2 remotes, the original that came with the garage door, and another one that came from a system added afterwards to the garage door, both working at 433.92mhz.

Also, the receiver would theoretically be able to read signals from a car key’s central locking, right?
I’m starting to think it might be broken… is there a way to troubleshoot it? Maybe using another mcu with the transmitter and tryng to receive the signals from that one?

//I have also tried the ‘ProtocolAnalyzeDemo.ino’ example, still no output

0 Likes

#4

That’s correct.
I’m not a fan of using D numbers, I prefer to use GPIO numbers.
Some GPIO pins aren’t suitable for use with sensors, and GPIO15 isn’t a great choice. See this thread for more info…

Provided you connect it up correctly, this hardware is pretty-much bulletproof. Powering it from 5v or 3.3v on the NodeMCU works fine for me.

I think the issue is that RC Switch just isn’t recognising the 433MHz commands, so isn’t producing any response. Exactly the same thing happened for me and I ended-up doing the Audacity thing, but in the post I made to the MySensors forum I provided a link to another utility which did work for my particular remote transmitter.

Car remote key fobs generally tend to use rolling code systems and you won’t get any joy trying to listen to them with RC Switch.

Pete.

0 Likes

#5

@PeteKnight so after pushind the open door button for about 100 times and not succeeding reading the signal, my remote also desynchronised. The garage door knows I’m sending the signal from the remote but I can’t open the door. I’m assuming the remote sends different signals every time(for security reasons) and I pressed the button too many times, causing them to ‘desync’. If this is correct, wouldn’t it be theoretically impossible tryng ti open the garage door with the signal I’ve read from the remote? As this is different each time

0 Likes

#6

I doubt very much if the remote uses a rolling code system. If it does then you should be able to detect the code using the 433 receiver you have, but obviously repeating the rolling code sequence is extremely difficult, if not impossible.

Is it possible that the battery in the remote needs replacing?
Most receivers have a pairing button, usually doubling as a way of clearing the stored remote codes.

Have you tried the sound card and Audacity solution yet?

Pete.

0 Likes

#7

Yes, I have tried replacing the battery. As I said, the module receives data from the remote (it has a digital display that shows when data is being received). There is a way to reset the remote in the user manual, I will try it asap.

I have’t tried using the soundcard yet, I’ve had a pretty busy week and I’ll try it as sion as I get the remote to work again.

0 Likes

#8

Hi, there is nothing wrong with your hardware, you just trying to sniff a not supported protocol from this library, if you do by hand, not library it will work.

0 Likes