Problem migrating to the new Blynk

Im having some issues migrating to the new Blynk plattaform.
When I add this…

    #define BLYNK_TEMPLATE_ID "TMPL4cytDW11" //not real values
    #define BLYNK_DEVICE_NAME "TemplatePrueba"
    #define BLYNK_AUTH_TOKEN "w3K-7Bo47IB0yaeYaNOXIaEtKjgm8-11" //not real values

…to the code, the board keeps rebooting, with this info on the Sertial monitor:

> [51] Connecting to TucoWifi
> [2554] Connected to WiFi
> [2554] IP:
> [2554] 
>     ___  __          __
>    / _ )/ /_ _____  / /__
>   / _  / / // / _ \/  '_/
>  /____/_/\_, /_//_/_/\_\
>         /___/ v1.1.0 on ESP8266
>  #StandWithUkraine
> [2564] Connecting to
> [5776] 
>  ets Jan  8 2013,rst cause:4, boot mode:(3,6)
> wdt reset
> load 0x4010f000, len 1384, room 16 
> tail 8
> chksum 0x2d
> csum 0x2d
> v614f7c32
> ~ld
> [48] Connecting to TucoWifi
> [2551] Connected to WiFi
> [2551] IP:
> [2551] 

I’ve reduced the code to the bare minimun (see below), to switch between the old blynk and the new one.
With the old bynk, the board works ok and can connect to the old app.
When I add the lines to connect with the new blynk, it connects, but keeps rebooting forever with rst cause:4, boot mode:(3,6)

What can be the problem?? :persevere:
Thank you very much.

    //for NEW BLYNK
    #define BLYNK_TEMPLATE_ID "TMPL4cytDW11"
    #define BLYNK_DEVICE_NAME "TemplatePrueba"
    #define BLYNK_AUTH_TOKEN "w3K-7Bo47IB0yaeYaNOXIaEtKjgm8-11"

    #define BLYNK_PRINT Serial
    #include <ESP8266WiFi.h>
    #include <BlynkSimpleEsp8266.h>

    //char auth[] = BLYNK_AUTH_TOKEN; //for new Blynk
    char auth[] = "3460ae1237bc48afbd305fea68f88011"; //For OLD Blynk
    char ssid[] = "TucoWifi";
    char pass[] = "VIVAPEZ88";

    void setup()
      Blynk.begin(auth, ssid, pass);

    void loop()

Same board , last firmware, same power supply? :thinking:

@Luciano Please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your code so that it displays correctly.
Triple backticks look like this:

Copy and paste these if you can’t find the correct symbol on your keyboard.

Please do the same for your serial output so that displays correctly too.

Don’t use Blockquotes or indents like you currently have, they don’t work properly.


1 Like

I’ve tried with two boards NodeMCU and Wemos, same problem with boths boards.
Also tried powering from pc-usb or with phone charger, same problem.

With old blynk works Ok, with the new blynk lines, the board reboots constantly :persevere:

The code you’ve posted couldn’t have created the serial output you’ve posted. It would help if you posted the actual code that produced this output.
It would also have helped if you’d removed the Blockquotes and indents before applying the triple backticks.

Have you set-up any digital datastreams in Blynk IoT?


Hello. Its working now.
I deleted the template and created a new empty template.
Previously I’ve added some switchs to digital pins (on the app), and maybe that was making the board to reboot.
Thank you.

1 Like

Maybe you chosen not allowed gpio pins .
See the esp8266 pinout reference