Problem in connecting BLE to ESP32 board

I had uploaded the standalone code of Blynk BLE as mentioned below and tried connecting to the device ESP32 , initially it got connected and when I tried to connect it again, it was not connecting. Anyone faced this issue?


/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial

/* Fill-in your Template ID (only if using Blynk.Cloud) */
//#define BLYNK_TEMPLATE_ID   "YourTemplateID"

#include <BlynkSimpleEsp32_BLE.h>
#include <BLEDevice.h>
#include <BLEServer.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "KcKucr4uIYEndW5PUols--AUVKnaF_7O";

void setup()
  // Debug console

  Serial.println("Waiting for connections...");



void loop()

Is this a Legacy Auth token, or an IoT Auth token?
Which version of the Blynk app and Blynk library are you using?


Hi Pete,

It is a Blynk Legacy auth token and the Blynk Library version 0.6.1.

Are you seeing the “Blynk” device in the BLE widget in the Blynk app?
If so, what does it say when you try to connect?
Screenshots would be helpful.


Hello Sir,

“Blynk” is seen on the app in the ‘select device list’ however when I select it,connection is not established. I am attaching screenshots from the app as below;

Hello All,

My Blynk legacy BLE connection issue is resolved now. I don’t know if it got resolved because I tried connecting off peak hour( tried after 12:30am). Multiple attempts were sucessful. Thank you.