BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Problem connecting to local server with ESP32

Why ESP32 don’t connect to local blynk-server?
Blynk-server ver. server-0.41.12-java8 (in Win8.1)
app ver. 2.26.2
App and server have been connected well. But esp32 don’t connect. Writing in port - “[4256925] Connecting to 192.168.0.100”. ESP32, app and server are connect to once wi-fi local network.

@4ebura I’ve moved this from the unrelated 4 year old topic where you placed it into a new topic of its own.

I’d suggest that you share more information about the exact serial monitor messages you are getting, and the code you are using.
Please ensure that all code is correctly formatted with triple backticks at the beginning and end, otherwise it will be deleted.
Triple backticks look like this, please copy and paste them if you can’t find the backtick symbol on your keyboard:
```

Pete.

@PeteKnight OK. Thanks.
Serial monitor messages
image
I used code from template.

#define BLYNK_PRINT Serial


#include <WiFi.h>
#include <WiFiClient.h>
#include <BlynkSimpleEsp32.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "my_auth";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "my_wf_ssid";
char pass[] = "my_wf_pass";

void setup()
{
  Serial.begin(9600);
  Blynk.begin(auth, ssid, pass, IPAddress(192, 168, 0, 100));
 }

void loop()
{
  Blynk.run();
}

I assume that your local server is at 192.168.0.100 ?

I think you probably need to specify a port…
Blynk.begin(auth, ssid, pass, IPAddress(192, 168, 0, 100),8080);

The port will depend on what you’ve configured on your local server.

Pete.

Yes. Local server is at PC with Win8.1. Local adress 192.168.0.100
I used instruction from here: youtube tutorial
And used info from this source - port 9443.
I tried this code. It didn’t work too. ((

#define BLYNK_PRINT Serial


#include <WiFi.h>
#include <WiFiClient.h>
#include <BlynkSimpleEsp32.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "1OJSgSHY72SQItP80ZF7nYmxpCHUy-xr";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "universe";
char pass[] = "vlozab8002";

void setup()
{
  Serial.begin(9600);
  Blynk.begin(auth, ssid, pass, IPAddress(192, 168, 0, 100), 9443);
 }

void loop()
{
  Blynk.run();
}

Not sure about port 9443 unless you have an SSL certificate installed.

Pete.

@PeteKnight, thank you very much ))) Now it is working. It was stupid mistake. Thaks!

Hello, what was the solution?

Probably the port… normally it is 8080

Hey @Gunner was going to send you a PM but you got em turned off??

Yep. I now only pop in when I darn well feel like it :innocent: And can go for days/weeks/months in between logins, so it is just better for me to have them locked out, else I get inundated with PM “help meeees” upon return.

I hear ya… was going to drop you a line none “help me” :rofl::joy::rofl: