BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Port forwarding issue

I have a working local blynk server:)
I have also port forwarded 9443 and 8080 and checked them working fine on portchecktool.com
But the app won’t connect to the server when I use mobile data(outside home)

This image is what i keep on seeing indefinitely…
Any suggestions to overcome this?

Are you sure you have forwarding 9443 to IP local server ?
check the local IP server, is it a static IP ?
Try to forward 443 and connect blynk to 443 intead of 9443
I use that port , not 9443

Yes, the local IP Server is static
2)

How do i check this?!

To do this, i only have to change to port 443 from 9443 during login right??

  1. Im still not able to use local server using mobile data after considering points (!) and (3)

yes, forward 443 port on your router and connect to 443 w/ blynk app

I’m still facing problem in accessing local server from outside home…
I did the following, please tell where i’m going wrong :

  1. created a local server, works perfectly at home
    2)forwarded port 9443,8080,443 on router, and 9443 says ‘open’ on portchecktool.com
  2. when i try to login using custom settings on port 9443, local server, outside home network, the loading window(three green dots) would show endlessly

What IP address are you using in your custom server settings screen?
Do you have a static external IP address, or are you using a DDNS service?

Pete.

As @PeteKnight said, you have to know if you have a static IP address, or you just have a dynamically allocated IP address from ISP.
I’ll explain the steps more clearly for each scenario:

A) Dynamically Allocated IP Address from ISP

  1. If you have dynamically allocated IP address (normally, more than 99%), e.g. 45.45.a.b, and your local server is in local network @ 192.168.0.100.
  2. Forward all ports 9443, 8080, 443 to your local Blynk Server @ 192.168.0.100
  3. Get a free DDNS service at duckdns.org, noip.com, etc… For example you get a DDNS account yourname.duckdns.org. You can try if it’s working by pointing your WebBrower to
 https://yourname.duckdns.org:9443/admin

to access your Local Blynk Server admin page.

  1. In your phone/tablet APP, select server : yourname.duckdns.org and port: 9443 instead of your local server IP 192.168.0.100. This will work no matter if you’re using inside or outside network.

If it’s working, you certainly have to follow several more steps to ensure yourname.duckdns.org is always automatically updated with correct dynamically-allocated IP address whenever your ISP assigns a new IP address (router reboot, etc…).

B) Statically Allocated IP Address from ISP, e.g. 45.45.a.b

  1. You just need to forward all ports 9443, 8080, 443 to your local Blynk Server @ 192.168.0.100
  2. In your phone/tablet APP, select server : 45.45.a.b and port: 9443 instead of your local server IP 192.168.0.100. This will work no matter if you’re using inside or outside network
  3. It’s always better to use DDNS, just in case something happens, and especially you don’t need to remember complicated IP Address 45.45.a.b, but just yourname.duckdns.org

In some special case, ISP uses a double NAT, then you have no way to reach your server from outside, unless you deal with ISP to change (and pay some more). Do a search on double NAT in this forum if necessary.

I was using my computer’s local ip address until now, but now I’m using ddns service, as said by @khoih and it works perfectly… Thank you so much for the support!

Thankyou so much…I’m really happy this worked after weeks of trying…this wasn’t possible without your guidance @khoih
Thanks again!

Just so that you’re aware for the future, your local IP address isn’t visible outside of your network. There must be hundreds of millions of routers that sit at 192.168.1.1 on a local network, but that doesn’t mean that you can access them external on that IP address.

It’s the public (WAN) IP address that needs to be used, and the router needs to be configured to send the appropriate traffic to your internal device (your Blynk server in this case). That’s what the port forwarding does.

If your public IP address changes from time to time then you need to use a DDNS service to route traffic to the current public IP address for your network. For this to work, you need to have an update client running on your network that keeps the DDNS service updated with your current IP address whenever it changes.

Pete.

1 Like

To know your Public IP, just go to http://www.portchecktool.com/
You can see your public IP and scan port

Thanks for the information and all the support! :smile:

1 Like

My problem is I can use https://mydomain.com:9443/admin to access my local server’s web admin page. Just like this picture. But my app use “mydomain.com” and port 9443 can not connect to server,why?And what can I do?

image

When I change server port to 443, admin page can not open yet,you sure this is right?

There are too many things can happens

  1. Wrong Blynk Server settings (SSL, etc.)
  2. Phone Service Provider blocks the services (DDNS, SSL, certain IPs)
  3. Wrong Router settings.

To isolate the issue, only you can do by following steps by steps

  1. Connect phone to local WiFi. Access Blynk Server using local IP and port 9443.
    For example: server: 192.168.100.100 and port: 9443

If OK, the phone APP and Blynk Server settings are OKs.

  1. Still connect phone to local WiFi. Access Blynk Server using DDNS domain name and port 9443.
    For example: server: mydomain.com and port: 9443

If OK, Router Port Forwarding settings are OKs. The ISP is already OK (no double NAT, service blocking, etc…) as you already can access the Server Admin page using browser and DDNS domain name.

  1. Disconnect phone from local WiFi. Access Blynk Server using DDNS domain name and port 9443.
    For example: server: mydomain.com and port: 9443

If OK, your problem is solved magically. If not OK, your phone service provider / Government is blocking services.

1 Like

In my case:

  1. I can use app to access blynk server and control my all hardwares with home wifi
  2. I can open blynk server admin page using domain name(with port 9443) from outside of home with phone.See picture below. It seems my ddns is ok,right?
  3. But My app can not connected to blynk server using same domain(with port 9443) .It always get this screen:

    I don’t know why?Do I have anything set up? I am going nuts! :joy:

So you’re out of luck and no magic happens yet :wink:

If not OK, your phone service provider / Government is blocking services.

But why I can open admin page from outside? It doesn’t make sense.

I want to know is whether the APP is only using port 9443, if the Admin page can be opened, if the APP can connect?