BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Ota wifi port not appearing for wemos d1 mini

@perigalacticon which version of the Arduino core are you using 2.3.0 or later?

I have a very “busy” Windows 8.1 system and bridged routers etc. Invariably I will have 100+ Windows open if you include 4 instances of Chrome. dozens of tabs open in each plus Arduino sketches galore,email etc, etc.

Quite often I find the port doesn’t show in the IDE which then requires a reboot and this can take 10 minutes or more.

I have a much “cleaner” Ubuntu system and that doesn’t have any problem seeing the ports. It could be the different networking protocols between the two OS’.

To be able to see the ports you must have the Bonjour service running on Windows. For my busy system I believe the service simply stops and trying to manually restart it doesn’t help. Bonjour gets installed with printer and networking software but it might be you don’t have it. Check your services.

The other issue when the ports do become available is that you will not be able to do an OTA update until you have unplugged the WeMos as least once since the last flash.

In the newer versions of the core and with verbose compiler messages set there is a message to the effect “numpty you haven’t rebooted since you last flashed”. Even though I am aware of this feature in ESP8266’s I still get caught out from time to time especially as I am reflashing minute by minute through the day.

When you flash via OTA the powering off is not required but during testing a lot of the flashing is via the USB port and hence the feature presents itself. In the real world Espressif are right that when you do a local flash and then take or send the ESP to a location where you are going to use OTA it will have naturally had the required reboot.

HTH

1 Like

I have Bonjour service it is running. I downloaded the Bonjour browser and it shows nothing is running.

Do you have access to a different OS on another PC?

I programmed the BasicOTA sketch, I disconnected it from USB, and connected to 5V power, and pressed reset. The led blinked 4-5 times and stopped. I went to the IDE, no OTA port was showing. I restarted the IDE, no OTA port is showing. Nothing is showing on the Bonjour Browser. I have an Android tablet?

I{ just saw that although the Services shows Bonjour as “Running”, under properties it shows “Stopped” I started it, but nothing changed, I restarted the IDE etc and no OTA port.

They answered your GitHub post within 18 minutes which is a pretty good service if you ask me. Especially as they will say GitHub is not really the right place. Their forum is the correct place.

As per the GitHub reply it’s probably your Firewall.

Just tried my wife’s relatively clean Windows 10 that has the Arduino IDE on it. At first no ports were showing and then I switched to the correct router and all ports appeared without any IDE restarts etc.

Maybe forget your WiFi network and reconnect saying yes to any prompts about local network access. Some people are fearful that this is opening up their computer to attack but as long as your local network is safe then you should allow full access, unless you want to abandon OTA.

Failing this do a thorough search through your firewalll settings.

A few other things to look at…

  1. Are you 100% sure that both your PC and your Wemos are connected to the same Wi-Fi network? I’ve seen a situation where a a dual-band router was being used an the MCU was connected to the 2.4ghz network and the PC connecting to the 5ghz network (which had the same ssid) and the router want bridging the two connections.

  2. If your router is set-up to use IPv6 then try turning this off.

  3. Ditto with UPnP.

  4. As @Costas said, its likely to be a firewall issue. Try turning off Windows firewall altogether.

Pete.

Restarted windows, now Bonjour is running, But the same procedure gets the same results. No OTA port is showing. I tried turning off the antivirus, Avast, no change. I see it says Java platform is allowed.

The port showed up after some combination of turning off the firewall and starting Bonjour and restarting the IDE And windows.

However now I have errorx during uploading:

05:17:48 [ERROR]: No Answer
05:17:48 [ERROR]: No Answer

and when I retried:

Uploading…
05:24:04 [ERROR]: Error Uploading
05:24:04 [ERROR]: Error Uploading

That is the feature I referred to. Press the reset button on the WeMos after every local flash.

So it was your problem and not the Arduino IDE and libraries etc.

1 Like

Ok Now I can upload. :slight_smile:

I don’t know ‘who’s at fault’ here really but all I know is the system doesn’t seem to work very well, or at least is not documented very well officially. I’ll have to find out how to let Avast selectively allow this activity.

I really appreciate your assistance it is a feature with major benefits that I was really looking forward to.

Thanks again. I hope anyone that finds this in the future may be helped by it.

1 Like

Ahh, just blame it on global warming :wink: OTA works very well and it is all very well documented, just requires a modicum of research.

Glad you finally got it working… on to the next challenge!

1 Like

No, it’s not well documented, I spent an entire day trying to figure this out, taking many, many troubleshooting steps that cost me an entire day’s worth of work on a project I am behind on already. So I completely disagree with you, but thanks again for your help. Maybe don’t take things so personally.

I found that first post I sent you the link to (that you didn’t click on) in 5 min… it referenced all the things you tried.

Nothing personal, just trying to help… leading a donkey to water and all that :wink:

1 Like

:thinking:
Careful with the use of idioms!
A little bit strange for a non-native English speaker like me…:wink:

5 Likes

I am sure almost everything i say is a little strange to all languages :stuck_out_tongue:

@PeteKnight too funny :rofl:

Definitely… Sometimes I need to read twice your posts to understand…imagine using idioms! Crazy :sweat_smile:

If you ever need clarification just PM me :slight_smile:

1 Like