BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

OTA ip address, use external ip instead of external ip

Hello everyone,

I was trying to perform OTA for a device I have set up on a private server hosted on Google Cloud. Upon executing curl -v -F file=@blynk.inject.ino.nodemcu.bin --insecure -u admin@blynk.cc:admin https://x.x.x.x:9443/admin/ota/start?token=x i get the request to my connected device but the IP address of the file is the internal IP address of my VM instance. I tried to use the -H parameter with the curl command to get the external IP, however, the internal IP is still sent to the device.

My question is how I can point the OTA to my external IP instead of the internal one.