Only a view seconds online after Ping via SIM900 and GSM

Dear all!

I have a problem with connecting a SIM900 Modul via GSM and GPRS. I tried Arduino Uno and ESP8266. It’s always the same situation. First it looks good, the connection works and gets READY (ping: 844ms) but after a view seconds the connection gets lost and the SIM900 Module never gets online again. While connection is okay also the device in blynk cloud is online.
I also tried with SIM800 modul. It’s always the same situation.
Power supply is a 18650 Samsung SDI batterie, so the supply is definitly not the problem.

Has anyone an idea what I can do to solve this problem?
Thanks in advance, Hans-Peter

11:58:39.763 -> Initializing modem...
11:58:47.495 -> [10720] 
11:58:47.496 ->     ___  __          __
11:58:47.593 ->    / _ )/ /_ _____  / /__
11:58:47.593 ->   / _  / / // / _ \/  '_/
11:58:47.594 ->  /____/_/\_, /_//_/_/\_\
11:58:47.598 ->         /___/ v1.3.2 on Arduino Uno
11:58:47.626 -> 
11:58:47.626 ->  #StandWithUkraine
11:58:47.690 -> 
11:58:47.690 -> 
11:58:47.690 -> [10862] Modem init...
11:58:48.734 -> [11955] Connecting to network...
11:58:54.910 -> [18153] Network: HoT
11:58:54.942 -> [18153] Connecting to ...
11:58:58.723 -> [21954] Connected to GPRS
11:58:58.989 -> [22235] Connecting to
11:59:01.770 -> [25013] Ready (ping: 839ms).
11:59:08.959 -> [32167] Connecting to
12:00:25.074 -> [108226] Connecting to
12:01:43.197 -> [186320] Connecting to

#define BLYNK_PRINT Serial

#include <TinyGsmClient.h>
#include <BlynkSimpleTinyGSM.h>

char apn[]  = "";
char user[] = "";
char pass[] = "";

#include <SoftwareSerial.h>
SoftwareSerial SerialAT(2, 3); // RX, TX

TinyGsm modem(SerialAT);

void setup()
  // Debug console


  // Set GSM module baud rate

  Serial.println("Initializing modem...");

  Blynk.begin(BLYNK_AUTH_TOKEN, modem, apn, user, pass);

void loop()

@da_fessor Please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your serial output so that it displays correctly.
Triple backticks look like this:

Copy and paste these if you can’t find the correct symbol on your keyboard.

I’d suggest that you also post your sketch, also with triple backticks at the beginning and end.


Do you plan to do this?


Thank you!
It would be great if someone could help me with my problem.

Is this a 3.7v battery?
Are you powering your Uno and the SIM900 from the same power source?

If not, can you explain more, and explain the type of SIM900 board you’re using and its power requirements?


It is a fully charged 4.15V battery. The arduino is powered by USB. I also tried with laboratory power supply. In my opinion there is enough power coming from my battery.
I also tried to add a capacitor in parallel.

The SIM900 module is SIM900A MINI V3.9.2 and the SIM800L is the well known “red module”.

I also use thick wires!

Common ground?


Yes common ground.

Now it works!!!
I don’t have an explanation for it yet, but it’s not possible to use pin 2 and pin 3 for software serial communication with Sim900 module.
I changed RX and TX to pin 7 and pin 8 and everything works fine!

Maybe this information will help also others.

Maybe you have a problem with your Uno.