BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

OMV+Docker, E-mail and Dashboard

Hello, I’m using OpenMediaVault and Docker to run my Blynk server.

I got Blynk image from mpherg, I can access admin web page and create account from my Android device, that’s fine.

BUT I can’t find a way to config mail.properties, I can modify server.properties file that I’ve bind the folder to Docker.

Things that I’ve tried:

Put mail.properties within server.properties folder
Nothing happened

Open Admin Dashboard to edit from there
I can edit, save, but when I leave and open again, the config didn’t save.

After leaving and editing again it just reset to:
"mail.smtp.username=example@gmail.com"

I didn’t find any information about mail properties in docker, neither why after saving It does not save at all in Dashboard.

I can provide more info about installation if needed.

I don’t think any editing in the dashboard works properly… saving for later development?

Just use text editors in the folder and create/edit your file that way.

1 Like

Thanks for your reply!

So far I managed to use my server.properties and editing it with a text editor, but I cant find where to put my mail.properties

Just to clarify, I have a server running OpenMediaVault, running Blynk in Docker (which have his persistent folder), and the Docker folder of “/config” is shared over SMB to my notebook.

The /config folder is where I put my server.properties and works fine, but I’ve tried to put mail.properties there and didn’t work.

I have /data folder persisting too, where I can put my .pem files, have my .user files, and logs… Acutally, all data related. Tried to put mail.properties there but didn’t work too:

Since I don’t know where mail.properties should go and dashboard editi isn’t working, I’m lost here.

It goes in the same directory.

1 Like

Hello! It’s very odd since I have mail.properties inside my /config (with server.properties that work, if I edit this and restart Docker I can see the change in Dashboard) and inside my /data

If I run server in my Notebook using java using same files instead of Docker the e-mail config works, but I need it in my server :roll_eyes:

You can’t set mail.properties through the admin panel. You need to simply edit it with a text editor like Nano.

1 Like

You give me a clue of what to do and I’m gonna document it here so if anyone have same problem can try to do this:

First I oppened my server terminal, then I run

docker exec -it blynk bash

Blynk is my container name, if the container is named banana you should type banana instead

This will let you bash INSIDE docker container.
The default folder when I entered was /data (this is where my mail.properties was), type

cd /

this will move you to “root” of container

Here I had a folder named blynk, when I opened it I can see it have the “server.jar” file

You may need to search where is your “server.jar” navigating trough folders using ls (to list folders) and cd “foldername” to enter it, and using ls again to view files inside that folder.

Back to root (“cd /”) I send the following command:

cp /data/mail.properties /blynk/

Now you can enter the folder where “server.jar” was (mine was “blynk”) and type ls, you need to see your mail.properties with server.jar
This will copy yout mail.properties from /data to /blynk folder, then I restarted docker container and it works!

1 Like

Hi Hlino,
I’ve OMV3 and various docker runing (unifi, logitech media server…) and all ok, but I’ve a problem with Blynk, don’t start. In the log “service stopped”. Can you help me to configure the docker plugin for run in OMV?

Very Thanks
Andrea

1 Like

Can you post your command to launch the docker instance @ackio ?

What os are you on?

Hi,
I’m pretty new to docker.
Could anyone explain how to configure Blynk docker inside the GUI of OpenMediaVault?
Any hints to where I can read more about that topic are welcome.
Thanks.

I just came through this thread and was not totally happy with the given solution because this way, the mail.properties file inside the container will be lost each time you upgrade the container.

Instead, you can simply mount the file directly to the /blynk folder by adding:

-v /path/to/mail.properties:/blynk/mail.properties