Nvidia Jetson Nano with Blynk server and Node Red

For about 7 year I think I’ve been running a Blynk local server with Node Red as well as other local programs and the Jetson Nano has worked flawlessly for years until I started getting issues with Docker conflicts.

Roll on a week and now the server fails to boot and I’ve lost everything as it appears after 7 years and using the Jetson Nano as TFTP, FTP, NodeRed, Blynk, Orbico, PiHole (yes it can work on a Jetson Nano) OpenVPN, InfluxDB, Prometheus and Grafana server, I think the MicroSD cards write cycles fell over. I noticed the swap file was also at 99% all the time a few days before the card fell over (WebMin dashboard).

I’ve moved everything to another card what had been backed up but the Node Red and Blynk proved to be a pain as nothing was backed up.

I programmed my Node Red to link up to the virtual pins of and display dial of the weather in my shack and garden but I lost the original ingredients and worse off the website I had used to get this data has now been deleted.

Can some kind soul please give me a back to basics for getting data from my Blynk server as I managed to move a clone from a Raspberry Pi I had run along side. Right now I’ve managed to get NodeRed installed using docker on the Jetson nano and Blynk is on a Raspberry Ali until I come up with a different solution.

I see some tutorials on http injection, Blynk ws write and obviously NodeRed UI but what isn’t happening is pin connected when I deploy the ingredients. I’ve got the API key copied and tried to use old tutorial but the ones on the internet are so out of date with the latest version of NodeRed (I’m using 3.0). Most of the tutorials are 1.5 or something?

Please no comments on “all eggs in same basket” as there was also an apache server scrapping weather TLE (two line elements) from Celestrak so that my satellite antenna can track NOAA and MeteoSat satellites. The point is there was only one IP and one group of ports behind a VLAN exposed to the Internet. This made it bullet proof and from a Cisco network point of view the perfect isolation from the rest of my equipment. Any outside interference should have met resistance with Fail2ban and other blocking scripts.

NodeRed really isn’t my strong suit but asking NodeRed forums about Blynk will only result in “ask a Blynk forum”. So I’m asking here if anyone could please give me some back to basic pointers as I haven’t used NodeRed or fiddled about with the Blynk server in 3 years or more as it’s run flawlessly. It was the perfect server as it was also silent and had a 3 days UPS attached too.

Thanks in advanced.


If you’ve installed node-red-contrib-blynk-ws from the pallet manager and created a new connection to your Blynk Legacy local server and specified the correct port and it’s not working then I guess it’s going to be an issue with port mapping in your Docker.

I tried Docker once and hated it, so I don’t have any real knowledge of how to get around that issue.

My solution is to run Node-Red on a Raspberry Pi 4 with an external SSD rather than using an SD card. The SSD is far more robust and also faster, but backups are of course also a good idea :grinning:

I don’t really have a basic “getting started” tutorial, and if I did it wouldn’t cover Docker, but there’s some stuff buried in this topic…


Cheers I shall give it a whirl