Not able to login in local blynk server on windows laptop


I have installed the local blynk sever on my windows laptop.

It is showing running but not able to connect with my android mobile with custom setting.


And on mobile blink app it is showing only “Reconnecting to the server…”

Please help to resolve this issue.


Please provide more details…

Have you created an account on your new server before trying to log into it… You can NOT use the same account as you had on the cloud… well, actually you can use the same email and even password if you want (from Cloud), but it will still be a totally separate server and new and empty account, until you start creating projects in it.

What are you entering in your custom settings… and are you inside of your network at the time and using the correct IP and port to your laptop?

I follow the process as below:

  1. I install the server locally on my laptop and it shows it is runnng.
  2. After that i download the blynk app on my androaid mobile and click on ‘Create new account’
  3. And in blynk app I set my laptop IP that is with port 8443.(I have connected my laptop with the wifi internet router)


  1. Then I put my email id and password as i want, and click on signup.

Is this process is ok? Please let me know if i missed anything.


Here is the admin panel for your reference.

App port is 9443, it was changed many months ago… are you following the official Server install directions?

yes I followed the official server install directions.

And I tried with 9443 also but it is showing the same ‘Reconnecting to the server…’ message on my ‘Create New Account’ page on blynk mobile app.

Pls guide me.Thanks

Then how did you get the wrong port?? The number 8443 doesn’t even show up on a search of that link I provided :wink:

I don’t use my Local Server on Windows. All I can suggest is double check all your settings, paths, IP (hint… NOT the same IP you used for the Admin page), ports, etc… and make sure the server is actually running at the time… if you close the terminal window, the server shuts down.

yes … I have installed local server before 2 days back.

Below is my server properties:

#hardware ssl port

#hardware plain tcp/ip port

#http port

#web sockets ssl port
#web sockets plain tcp port

#https port

#application ssl port

#by default server uses embedded in jar cert to simplify local server installation.
#provide either full path to files either use '.' for specifying current directory. For instance "./myfile.crt"

#Blynk server allows to use 2 hosts for same IP, below properties for second host


#by default System.getProperty("")/blynk used

#folder for logs.

#log debug level. trace|debug|info|error. Defines how precise logging will be.

#defines maximum allowed number of user dashboards. Needed to limit possible number of tokens.

#defines maximum allowed widget size in KBs as json string.

#user is limited with 100 messages per second.
#in case of consistent quota limit exceed during long term, sending warning response back to exceeding channel
#for performance reason sending only 1 message within interval. In millis

#maximum allowed number of notification queue. Queue responsible for processing email, pushes, twits sending.
#Because of performance issue - those queue is processed in separate thread, this is required due
#to blocking nature of all above operations. Usually limit shouldn't be reached.

#Number of threads for performing blocking operations - push, twits, emails, db queries.
#Recommended to hold this value low unless you have to perform a lot of blocking operations.

#this setting defines how often we can send mail/tweet/push or any other notification. Specified in seconds

#maximum size of user profile in kb's

#period in millis for saving all user DB to disk.

#period in millis for saving stats to disk.

#specifies maximum period of time when application socket could be idle. After which
#socket will be closed due to non activity. In seconds. Default value 600 if not provided.
#leave it empty for infinity timeout
#specifies maximum period of time when hardware socket could be idle. After which
#socket will be closed due to non activity. In seconds. Default value 15 if not provided.
#leave it empty for infinity timeout

#Enables native socket transport for Linux using JNI. Should be turned on only if you 100% sure.
#may not work on some environments. Used to increase server performance. Performance boost is ~20-40%.

#Enabled native openSSL support for SSL handlers. Should be turned on only if you 100% sure.
#may not work on some environments. Used to increase server performance. Performance boost is ~16%.
#For more details see -

#mostly required for local servers setup in case user want to log raw data in CSV format
#from his hardware

#size of async logger ring buffer. should be increased for loads >2-3k req/sec



#administration https port

#reset pass port
#host for reset pass redirect. by default current server IP is taken. could be replaced with more friendly hostname.
#it is recommended to override this property with your server IP to avoid possible problems of host resolving

#comma separated list of administrator IPs. allow access to admin UI only for those IPs.
#you may set it for to allow access for all.
#you may use CIDR notation. For instance,

#comma separated list of users allowed to create accounts. leave it empty if no restriction required.

This IP i used for admin panel:

And the ports look incorrect… please read or reread the proper directions…

That’s not the issue… clearly that works… what is the IP you used in the App? (not that it matters if your settings are wrong anyhow)

should i replace the server properties file content with the content as you mentioed in above link?

Sure, why not… what do those pesky directions say?? :stuck_out_tongue_winking_eye:

In App, I am using my laptop IP that is :

My laptop is connected with the wifi router.

That should be fine then… with the correctly setup…

#secured https, web sockets and app port

Listen, I can’t run through the whole setup with you… not when there are perfectly clear directions at the official links I have provided (I am working on my own stuff). And sorry, but based on all the wrong ports and such, I am not quite a believer that you have fully read them :stuck_out_tongue:

ok thanks…

it is showing the same after replace the server properties file content.

Is it working on windows?

Others have done it… so yes.

A thought just came to me… your antivirus probably blocking it… I seem to recall that being an issue with Windows. Searching this forum would probably clarify that.

Thank you.

can i use this link “” to send pin value to my raspberrypi ?

At right side is just a code or can I use the “switch to console” to set pin value on my raspberrypi ? or should i have to use a tool called postman for PUT method for blynk rest API.

Is this topic solved then?

As for other issues/questions, aside from searching this forum and reading the docs… make another topic so others can see the details and help with the API stuff (but simple answer is yes… if done properly :stuck_out_tongue: )

That page is just a demo and documentation… you will use the actual API command in a web browser or even in the Webhook Widget for cross-project data/command sharing.

Actually, local server problem is not solved.

So I am thinking to use the cloud server only and I will use the rest API.

Actually my aim is to access the raspberrypi from my own custom mobile app and control the LED.

So I think instead or local use the cloud server and use rest API in my own custom app to access the raspberrypi pin…

Is this a right way, what do you say?

Well look at the at AV issue… i am fairly sure that was the solution of other Windows Local Server users.

It is A way… but since the Blynk App is directly tied into the whole Blynk system (and the only non open source part), while you can use the API for external commands, you cannot NOT use the Blynk App.

You must use it to setup the accounts and projects in the first place… so this DIY App sounds like lots of extra redundant work to me… but fill yer boots :smiley: