Not able to Log in Blynk app through mobile data

Hello everyone,

I cannot log in Blynk app when using mobile data. I don’t have any issue when I use wifi connection on my phone (this is not an hardware issue)

• Android app (last version 2.27.14)
• Using Blynk server

I tried to ping with PingTools app, no response. I also tried to configure a custom server settings using differents ports (80, 443, 8080), didn’t worked.
My ISP probably blocks connections to Blynk server.

Do you have any workaround ?

If you are using the Blynk cloud server then you MUST use port 9443 for the app login. You could define a custom server with the IP address of your local Blynk cloud server which will be and port 9443 which may help if your phone/ISP is having issues with DNS resolution.

I wouldn’t necessarily agree. The WiFi and GPRS modems in the phone are separate, different and accessed different by the Android OS.
First thing I’d do is to restart the phone and if that doesn’t help then clear the network cache.
Try your SIM in a different device to check if it’s an ISP issue (very doubtful).


Using IP and port 9443 works with Wifi, not with data.

As hardware, I meant ESP8266, not the mobile phone :slight_smile:

Restart/Clear cache didn’t help.
Unfortunately, I don’t have any other phone to try my Sim card with right now …

I doubt the issue is about the mobile phone (for info, it is a Xiaomi) because I already log in successfully while ago.

The app’s connection to the Blynk server has nothing at all to do ywith the ESP. In fact, when you first log in to the app and create an account and project there are no devices known to the app project at all.

Well, it’s either your phone, your mobile service provider or the Blynk cloud server. The server status page shows 100% uptime for all three servers (your account is on the Frankfurt server), so it’s not that.

I’ve heard of some ISPs and mobile service providers blocking the Blynk data packets between devices (ESPs) and the Blynk cloud servers, but never between the app and the server.

So, my money is on the phone being the issue.
I don’t suppose you’re using a VPN on your phone are you?


Can you try next ip-addresses in custom server set up (with port=443):


One of them should lead to you blynk cloud server

@PeteKnight you are right, the phone is the issue. I tried to use the sim card with a different mobile phone (Samsung), it worked.

As far as I know, I don’t use VPN on my phone.
I tried to copy APN settings from Samsung phone to Xiaomi phone, didn’t help.
I clear all network settings to factory, didn’t help.
I delete all data/cache of Blynk app, didn’t help.

As I am not facing issues with any other app, I would prefer to not go with complete factory reset of the phone …

@BlynkAndroidDev last one lead to blynk cloud server with my project, the problem is that I can’t access to it from this my actual mobile phone using data network (works on wifi)

That’s where the evidence pointed.
Bad news for your phone, but at least you know know where to focus now. Personally, I’d back-up your phone, do a factory reset and download the Blynk app and check that it’s working. If it is then restore your backup and see if Blynk stops working again.


I’ve missed the point about another phone working fine with this mobile connection, as at first glimpse it looked like a DNS issue. I’ve tried to google Xiaomi restrictions for app’s modile data usage, can you check these settings:

Checked, data and wifi was allowed, so that is not the issue.
As I don’t really need to access my project with data right know, I am ok to spend a little time to try troubleshooting.

Ok, then the last thing I can propose:

  1. Install Blynk beta version (Google Play app, seach for Blynk, goto to Blynk app page, scroll screen till ‘Join the beta’ section’)
  2. Reproduce this bug
  3. Return to the very first start screen and make a long click on Blynk logo on it - it will propose to send logs (select Gmail or your mail app), so I can check them - maybe there will be some clues.

@BlynkAndroidDev done !

I’ve checked the logs - nothing specific, same errors as in the case with no mobile network.

This is the only App I have with this issue, I am able to connect through mobile network with all others apps, so it doesn’t look like an hardware issue imo.
I did a complete factory reset, with backup from my Google account, didn’t work.
I also tried to do a factory reset using a dummy Google account, without any data/parameters backed up, didnt work.


According to the app’s logs - blynk app has no access to the internet while your smartphone is on mobile data. The app can not change anything with that by its own, so I suppose there is some configuration on the devices settings’ side, or maybe some other side, like some firewall apps, for example.
We can’t help with it from the apps side.

Hi, I tried with a different sim card, from a different provider, it worked well. I found out on provider help forum that some other people with the same Smartphone brand also have data network issues with some apps. It seems that it comes from Ipv4/Ipv6 restrictions by the provider with some smartphone brands


Thanks, at least it is good to know about such issues, and that they can be caused by the provider. But they are still super strange to exist.