BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Nodemcu12E- Can't connect to cloud.blynk.cc:8442


#1

Hello everyone, I am having a bit of an issue. I am using a Nodemcu 12E to run Blynk but it seems that NMcu is having trouble connecting to the server. I am using the latest build of the Blynk Library (0.3.9) and the latest Arduino IDE 1.6.12. The error I am getting is:

Connecting to AlYi
[3769] Connected to WiFi
[3769] My IP: 192.168.30.32
[5001] Connecting to cloud.blynk.cc:8442
[11163] Connecting to cloud.blynk.cc:8442
[17538] Connecting to cloud.blynk.cc:8442

Note: The sketch I ran is from the example, Blynk> Boards Wifi> Esp8266_Standalone.

Thanks!


#2

That is because that is the old server. Please update to the latest library :slight_smile:

Hmm, that should be good, the latest, try the manual connect example and connect to blynk-cloud.com that should be the correct address.


#3

Are you sure you are using 0.3.9 as cloud.blynk.cc was removed from the libraries around 0.3.6?
This is how it should look when you connect.

[307] Connecting to OfficeGargoyle
[1808] Connected to WiFi
[1808] IP: 192.168.10.195
[1808] Blynk v0.3.9 on Arduino
[5001] Connecting to blynk-cloud.com:8442
[5248] Ready (ping: 5ms).


#4

Are you using the latest version of the app (1.15.3 for Android and X.XX for iOS)?

Android or iOS?

In the app for the connection settings is it set to default, presumably you haven’t disabled default and entered “cloud.blynk.cc” manually?


#5

Ok problem solved! It was weird though, I did use the 0.3.9 v but didn’t know why it didn’t work. This morning I uninstalled Arduino IDE and did a fresh install and after that flashed the sketch and it all worked! Makes me wonder that the old library somehow stayed and the new one didn’t completely remove it. Thanks guys!

p.s I am using the 1.15.3v for Android.


#6

Doing a fresh install of everything solved the problem. Thanks!


#7

Hello I am also having the same issue. My serial output:

[1315] Connected to WiFi
[1315] My IP: 192.168.1.203
[5001] Connecting to cloud.blynk.cc:8442
[11233] Connecting to cloud.blynk.cc:8442
[17507] Connecting to cloud.blynk.cc:8442
[23807] Connecting to cloud.blynk.cc:8442

1st, I have renamed

C:\Users\Tet\AppData\Local\Arduino15

This would mean that I have to download all the files pertaining to esp8266,

2nd, I moved the Blynk library folder which is located inside the library folder inside my “sketchbook location”

3rd, I unzip a fresh Arduino 1.6.12 to another folder and run the exe.

After all the moving and renaming.

  1. I install esp822 from the board manager
  2. Install Blynk lbrary from “Manage Library”

Any clue? Or how to solve?

Before all of these, I was playing with Oak by Digistump to run Blynk.
The board that have this datalog is from ESPERT V2


#8

You can’t install Blynk from the library manager as there are 4 libraries and they have to be manually installed as stated on the GitHub.


#9

Its always a good idea to DELETE the old Blynk related library folders first.
Issues arrise when you just OVERWRITE the current folders/files.


Trouble Connecting to the Blynk Server
#10

Hi, friend!
Can you tell me - how you can take the IP adress? I need to get IP adress of blynk-cloud.com in scetch

Whith mobile internet all working fine.
if I use the provider internet (not mobile) - the wire internet - NodeMCU not connecting to blynk-cloud.com. If I use ping in cmd and then take IP and use in scetch Blynk.config(auth,
IPAddress(xxx,xxx,xxx,xxx), 8080) - it works.
What i need - I need a code which is defines IP adrees of blynk-cloud.com.

Then i will take it and paste in Blynk.config(auth, IPAddress(xxx,xxx,xxx,xxx), 8080)


#11

@Piroteh, you already have a topic of your own about this issue. Reopening a topic that has been idle for well over two years isn’t the best way of trying to get a resolution to your particular issue.

There’s absolutely nothing wrong with hard-coding the IP address of the Blynk Cloud server where your project resides into your sketch, so I’d stick with that approach if I were you.
If you really wanted the ability to change this without re-flashing your NodeMCU then you could look at the idea of using Wi-Fi Manager to allow you to manually input the IP address, but in my opinion that’s not necessary.

I’m going to lock this topic. If anyone has comments about your issue they can post them here:

Pete.


closed #12