BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

NodeMCU Refuses to Go Online

So I have ran Quickstart template twice at my parents house and it works flawlessly. Code uploads to board and serial monitor displays all the online confirmation info. Go into web and mobile dashboard on BLYNK and everything is green and online. I am trying to get another esp8266 board online at a different house and it absolutely refuses to join network. the code loads to the board but NOTHING happens in the serial monitor! I’ve checked all access information 500 times, everything is correct. The serial monitor will display " …trying to join linksys" if I push reset button on board but it never does. 2.4g network and correct board chosen. Anyone have any idea how I can fix this and what the problem might be, extremely frustrating???

Have you tried a different network ?

Yeah i said it worked at a different house with a different network

These two statements seem to contradict each other. Either that or I’m misunderstanding the issue.
Could you clarify?

My first step would be to reboot the router, and triple-check that the SSID and password are correct (remember that both are case sensitive) and ensure that it really is a 2.4GHz network that you’re trying to connect to.
Maybe run a non-Blynk WiFi scanner sketch on the board to ensure that it can actually see the network that you’re trying to connect to.

Pete.

Yes I said nothing happens on the serial monitor “unless” I push reset on board. Yes everything has been checked a million times. Everything is right and network shows up on exact same board whe I run a 8266 wifi scanner.

If you had said that then it would have been much clearer.

Have you rebooted the router?

Pete.

I did say that. And yes I have tried the rebooting the router many times

The word “unless” added the clarity that I needed to understand your rather jumbled-up statement.

Clearly the issue isn’t Blynk related. The ESP8266 isn’t able to connect to the WiFi system in this second location, and until you get past that stage you won’t get anywhere.

Is there a WiFi repeater anywhere in the setup? If so then turn it off
Does the board connect to a hotspot created using a mobile device or laptop?
Have you tried uploading using the Erase Flash: All Flash Contents option?
Have you tried setting Debug Level to WiFi and Debug Port to Serial in the IDE?
Have you checked that the routers DHCP settings aren’t limiting the number of connected devices?

Pete.

Jumbled up statement? In your opinion maybe. How about you read more carefully? It was clearly all there. No wifi repeater .Board does not connect to different hotspots.

Assuming that you’ve checked-out the other things I suggested then I’d guess that the board is faulty.

Pete.

Now I know you’re not reading carefully. Board works just fine in a different house!! I said that already. Anyone else here have any ideas???

do you mean what you said here…

Maybe if you do this…

and share the serial output that results then some other forum members will be willing to take a look at that data and help you get to the bottom of what’s happening to cause this issue.

That obviously won’t be me though :wink:

Good luck.

Pete.

Blockquote

Not sure what you are missing here??? Someone else???

Maybe a simple “Thank you” from your side as @PeteKnight and @John93 have been really kind trying to help you with your problem…

Have a nice day.

2 Likes