NodeMCU ESP8622 onboard LED won‘t go off after using Blynk.begin()

I’m currently working on a project where roller blinds in the bedroom are controlled with a nodeMCU ESP8622. Everything works, only the onboard LED (GPIO16, D0) just doesn’t want to go out. I don’t need the light in the bedroom.

I tried it with

pinMode (D0, OUTPUT);
digitalWrite (D0, HIGH);

to turn it off manually, but it doesn’t work. This code is definitely the right one for switching off the LED, because I also tested it individually in a sketch.

After a lot of trial and error, I found that

Blynk.begin (auth, ssid, pass);

switches on the LED permanently. Any code in the Blynk library pulls pin D0 to LOW. Is there a way to deactivate this on the software side?

Try adding:
#define BLYNK_NO_BUILTIN // Disable built-in analog & digital pin operations

near the top of your code and see if that helps.

Having said that, GPIO16 isnt a great pin to use…


1 Like

Thanks, it was good to point out the pin assignment. I’ve redistributed the usage of the pins and the LED is off now. Thanks very much!

1 Like