Node red crash when adding blynk write node


I added a blynk write node:

But when I deploy this flow the Node red server immediately crashes and does not come to life anymore untill I restore the old flow (and credentials) from a backup

What’s happening with your Template ID ?
Is this the ID that you actually have in there, or have you edited it to redact the actual value?
The template ID should t have quotes around it.

Have you tried using a virtual pin number less than 126 ?


Hi Pete,

No I put in a edited template ID but it does crash with the correct template id.
I did have quotes around the template ID and no quotes around the auth token.

Using virtual pin 125 does not make a difference, Node red server still crashes

There should be no quotes around either.


same result (crash)

Have you tried doing a node-red-stop followed by node-red-start ?

Does this problem disappear if you remove the Blynk Write node, or do you have to delete the configuration node ?


Server does not start succesfully anymore, so I cannot update/deploy the flows anymore and I need to manually remove the following files from the server:

And restore them from an earlier backup. Then the issue us gone and the server starts again

Okay, try creating the config, but don’t add any nodes that use it, then stop/start the server. Is it the same?

You seem to be using Docker, is that correct?


found it, I was running a container with a very old node red version (0.2). Created a new container with the latest version (2.2.2) and now it does not crash anymore

1 Like