BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

No historical data on local server Superchart


#1

Hello,

I just finished building a local Raspberry and everything seem to be working fine.
I just realized that there is NO DATA on historical data, I can only see the live data.
With the same project, the historical data is working fine when switch to Blynk cloud server.
Please let me know what I need to do to allow historical data on local sever.
Thank you in advance.
Key


#2

Historical data implies there was a history… but if your local server is new… then no history :wink:

Local and cloud server are completely independent of each other… no shared data.


#3

The local server was up and running for 19 hours now but there is no data when I select 1hrs or 6 hrs :frowning:
I can only see data under Live view


#4

What server version?


#5

Raspberry Pi 3 B + with latest OS from Raspberry site


#6

:smile: That’s the platform, or whatever we call it. But please give us the
blynk server version


#7

How do I check for the server version?

I think I currently running the latest version that I can down load from the site.


#8

It is in the very name of the file you downloaded and ran for startup at boot.

What about the App version… what is it, and Android or IOS?

What is feeding the data?


#9

The version is 0.39.4-javar 8.
I tried both Blynk app on Apple iPhone and Android device, both device show NO historical data for 1 hr, 6hrs or 1 day. The live data is working fine.

With the same project, when I modified the cod to use cloud server then both live & historical data display data correctly fine


#10

Well I have no solid idea then… there have been many changes since I initially installed my server, over a year ago… but I am also running latest update 0.39.4-java8 and have no issues with SuperChart data.

Possibly something to do with your initial setup? I don’t know if Enabling Raw Data Storage needs to be done for something like basic Superchart or not.


#11

Thank you Gunner, you nailed it again.
By Enable Raw Data solved my problems.


#12

Yeah, probably some old settings overlaps with new server version. Installing server from the scretch should help here.