No connection or very bad connection with blynk server since yesterday (after coding error ?)

Hi all,

Thanks to read me.

I have been working on my project for several days without problem, but since yesterday I can no longer log in correctly to my account. Yesterday I made a programming error which caused too repetitive Blynk.virtualwrite ! (i think).
After this but not immediately after, i had no more connection or very bad and lost afetr few seconds.
Firstly, here are the error messages I captured.

> " [23354] Connecting to
[23364] <[1D|00|01|00] AuthTokenxxxxxx


> `[37841] Connecting to
[E][WiFiClient.cpp:258] connect(): socket error on fd 56, errno: 113, “Software caused connection abort”

i tried to change the token, it don’t work ==> on my box
I tried another account on the same box (same ip), it connects and it fall !
I had tried on my phone in modem mode, same thing it connects but with a very bad quality. Now i re swich on my box and same thing !???
See my code for testing (basic code, not my project code) and an extract of console.

My code below

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial
#include <WiFi.h>
#include <WiFiClient.h>
#include <BlynkSimpleEsp32.h>
// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
//char auth[] = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx";
char auth[] = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx";
// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "xxxxxxxxxxxxxxx";
char pass[] = "xxxxxxxxxxxxxxxxxxxxxxxxxx";
void setup()
  // Debug console
  Blynk.begin(auth, ssid, pass);
void loop()
  Serial.println("Connecté au serveur Blynk !!!");

And below that i see in console. Look at this weird codes between my “Connecté au serveur Blynk” message.

08:32:43.121 → Connecté au serveur Blynk !!!
08:32:43.220 → Connecté au serveur Blynk !!!
08:32:43.320 → Connecté au serveur Blynk !!!
08:32:43.419 → Connecté au serveur Blynk !!!
08:32:43.518 → [61170] >[14|1E]b[00|04]
08:32:43.551 → [61170] >vr[00]3
08:32:43.584 → [61170] >[14|1E]b[00|04]
08:32:43.584 → [61170] >vr[00]0
08:32:43.618 → Connecté au serveur Blynk !!!
08:32:43.651 → Connecté au serveur Blynk !!!
08:32:43.717 → Connecté au serveur Blynk !!!
08:32:43.816 → Connecté au serveur Blynk !!!
08:32:43.916 → Connecté au serveur Blynk !!!
08:32:44.015 → Connecté au serveur Blynk !!!
08:32:44.114 → Connecté au serveur Blynk !!!

please help me, i think i have tried many solutions and i am lost :hot_face: :cold_face:, i can’t do anything anymore. Are my account or my ip is not corrupted or banned by blynk ? because the other account doesn’t work properly no more when everything has always been functional with that one.

Thanks a lot for your help :grinning:


All code snippets should be formatted

Do not post your code blocks without proper formatting.
How to do that:


If you have already posted some code without formatting, you can edit it: find an edit button just below your post

Remove this from your loop . . .

This . . . will show you the Blynk connection status in the serial monitor.


PS . . . check this out

Thanks so much for the formatting code trick ! Better like that, i didn’t kwow :wink:
I don’t understand why you want me to remove the #DEFINE BLYNK_PRINT Serial, i need it to display variables to debug my program ? I have always used it without problems. Thanks

Bill didn’t say that you should remove #define BLYNK_PRINT Serial from your code, he said that it will provide you with the Blynk connection data that you need, so the Serial.println("Connecté au serveur Blynk !!!"); delay(100); in your loop isn’t required.


Hi Pete,
Thanks for your precision. I had no understand (i am french lol) …I just use serial.print to see my debug messages with all my variables. Here is just to show you with a basic example.

Could you help me for my question, i had many connection problems yesterday and all this morning with bad connections or not connection as show in my message. I don’t know why but now it is ok !!!
Could you confirm that the cause could have been too much virtualwrite request on blynk server (it was a mistake of myself), please tell me, i really want to understand where was this server issue connection. It made me crazy yesterday and this morning :hot_face: :hot_face: Have a good day

HI Gacaron,

French . . . lucky you! My wife I and planned to visit Carcassonne again in September, but . . . maybe next year . . .

Yes, all the serial.prints() in the loop will break Blynk . . . read the post about keeping your loop clean, since you removed the Serial.println() your sketch now works . . . that is why.

Good luck


If you had too many virtualWrites in your code at the time then this could possibly have caused the issue.
If you’re asking whether your device would then be “blacklisted” as a result then I don’t think so.

If you’re having issues like this then one think to check is the status of the cloud servers. Scroll to the bottom of this page to see the data:

Your project will most likely live on the Frankfurt server.

The other culprit, especially at the moment, could be your internet connection. If other people within your house are streaming movies or downloading large files (or even just running Windows Update) then your local bandwidth could be affected. If your connection to your ISP has a large contention ratio (many people sharing the same link to local internet backbone) then this could also be the cause of the issue.

Provided you aren’t doing anything silly with your code then you could try increasing the Blynk timeout (search the forum for details).


1 Like

Thanks Bill, Yes Carcasonne should be cool, but i never went lol :wink:
I know for the rule to let the loop clean, but that don’t make so much code and it runs like that with my test for hours for three month. I assume that my issue has been cause by many virtualwrites on the server ? What do you think of that.
Now to be sure i have made a setinterval call to a fonction (500ms) which contain my Serial.print. Is it a better way to do ? Thanks :wink:

Thanks Pete !
I saw your link, very interesting :wink:
My connection in ok now, i don’t know why. I had problems yesterday evening and early this morning (bad connection, disconnections …). Perhaps the server has no appreciated my coding mistake yesterday and made me pay :wink: lol
I have secured my code to avoid having to many Blynk.virtuawrite resquests.