New Blynk Library v0.5.1 is Released (important for local server owners)

Hey Marvin7, That worked.
Thank You so much. You’re a life saver.
Appreciate the quick response.

Glad it worked :slight_smile:

since I was successful with this I thought I would go ahead and do the server upgrade to version .0.33.0.
Bad idea. Nothing works with that version. Not even old esp’s that have been running for a year quit working.
So reverted back to 32.0.

I am running it… seems OK so far (only been a few hours). Open a new topic with details of the issues, logs, etc. so we can try to assist.

Old ESPs you have running are using port 8442, run this on your server:
sudo iptables -t nat -A PREROUTING -p tcp --dport 8442 -j REDIRECT --to-port 8080

This should work (it did to me)

1 Like

Good point… I make it a practice to reflash all my devices after installing every Blynk Library update.

I will make those routing changes in the router and try again tonight.
I have clocks on all my apps and have noticed that blynk can no longer keep up with the seconds. loses a second every 4 or five seconds.
Looks like all the changes are slowing everything down.
It appears to be server related. I have 2 apps that have been running for a year without any changes and now seconds display gets behind.

Thanks guys for your expertise.

1 Like

I am not a developer, so I might not have full enough understanding on the load the current App (and related library and server updates) puts on a phone or device, but I agree from a perceptual view that, as more and more “code free” solutions get added, there seems to be a cost in overall performance and flexibility. But then that is part of the market… the code free users :slight_smile:

So far, Local Server options and workarounds for some of these limitations have helped immensely… but then I also run into new issues… :confounded:

Oh well, the price of constant development… at least they are actively fixing issues and making improvements here :smiley: unlike many stagnating Apps out there.

There was some RTC discrepancies recently on one Cloud Server… but you are using Local Server, so might be something else… Make a new topic with device details and show the affected code…

Mind you… becasue of the interrelationship between App, Library and Server (Cloud and Local) updates… even “old untouched” devices will experience issues until re-flashed with updated libraries and any required code changes.

I agree with all.
The fact that they are constantly developing is great. I sure appreciate their work ethic and desire to make this a first class system.

A post was split to a new topic: Help with project since Server Library and App upgrades

Gunner and darkmoon

All is good now. everything works its just slow.

thanks for you inputs

Doing the port forward it’s working or you did something else?

Hello All,
i am using Raspberry PI as local Blynk server and also Blynk client. For client i use C++ library.
Now I upgraded library from 0.5.0 to 0.5.1 for Blynk client in raspberry PI and tried re-compile my source code in main.cpp.
I received error message
yield() is not declared in this scope
In version 0.5.0 i compilled my code without error.
Did I forget something to do during upgrade of library or it is some bug ?
Best Regards

Port forward.

Ok, you guys lost me here completely (and it’s just not very smart to change these default ports anyway…).

I updated to 0.33.2 and nothing works anymore. The hardware doesn’t connect. I explicitly specified port 8442 for non-SSL hardware in because I don’t want to flash all my devices.

So far it doesn’t seem to be listening at port 8442 … ? How do I fix that? I cannot connect any non-SSL hardware now :confused:

Well, I HAD to reflash all my devices. Just yesterday did it. Interestingly, the 0.31.0 were listening on 8080 already.

Guees it’s the way of the world …

We added new server on 8080 port. Waited 1 month for users to migrate to new version and dropped 8442 port.

1 Like

With a lot of swearing I finally managed to get everything back to work again. All I need now is new firmware on the devices with port 8080 hardcoded.

Please promise no more such changes in the future… :disappointed_relieved:


you can also redirect port 8442 to port 8080 on server… it should work for old devices.

sudo iptables -t nat -A PREROUTING -p tcp --dport 8442 -j REDIRECT --to-port 8080