BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Need help with IFTTT integration

Help !!! Help your brother, I used blynk app with nodemcu (esp8266), integrating it with ifttt & webhooks too. The blink buttons I created are perfectly working with action on the nodemcu. The Google Assistant is working too, but NO ACTION on the nodemcu.

  1. I login into ifttt with Google account (PC)also used in Google Assistant. & Later SWITCHED to MY MOBILE PHONE TO SIGN IN as you had instructed me.

  2. I removed APPLETS in IFTTT & restored/updated

  3. I used http://188.166.206.43/auth token/update/D16

  4. Method : PUT

5.CONTENT TYPE : APPLICATION/JSON

  1. 0 to ON and 1 to OFF, I pressed create action & finished

  2. I updated it too

  3. I’ve only 3applets in IFTTT and I used 2 only to trigger D16(gpio16) of the nodemcu.**

Buuuuuut, no action at all on the nodemcu hardware.

Help !

What else ? ???

@Leejin please don’t tag posts like this on onto the end of unrelated topics. I’ve moved your post to a new topic this time, but in future your post will simply be deleted.

Are you using Blynk Legacy or Blynk IoT ?

Pete.

Father, thanks so much for your paramount concern. I’m new here, so I never understand the rules, but I’ve understood you very well now. I’m using blynk legacy and my blynk buttons are working perfectly, I’m only having issue with the integration[google assistant] [webhooks failure]. In the first place , when my Blynk APP wasn’t connecting,so I followed the previous advice you gave to a blynk member…[ uninstall the blynk, reboot and reinstall] , I really appreciate for that, FATHER.

Hey there.

First your http link should look like this : http://blynk-cloud.com/4ae3851817194e2596cf1b7103603ef8/update/D8?value=1

replace blynk-cloud.com with your blynk cloud IP address.

Second use method : Get

Third Content type : Application/json

Try and let me know if it works.

Greetings.

1 Like

When you ping blynk-cloud.com from your PC, what IP address do you get?

Pete.

1 Like

Will for me it’s 188.166.206.43 but for him it could be something else depends on his location.

And that’s why your solution of…

won’t work (even when your auth token is replaced with his) because the IFTTT servers could be anywhere in the world, and will most likely resolve to the wrong cloud server and give an ‘invalid auth token’ error (which you don’t see in IFTTT). This is because the Blynk cloud servers don’t do re-direction on API calls.

First step in the diagnostic process is to work-out if the person is using Blynk Legacy or Blynk IoT.
The second step is to find which Blynk cloud server their project resides on, and ensure that its IP address is being used in the IFTTT URL.

Pete.

1 Like

It was a mistake, it’s been awhile since the last time I used IFTTT so I forgot to tell him to replace the blynk-cloud.com with his blynk cloud IP, I modified the post.

Thanks for your kind reminder.

Greetings.

1 Like

I’m very grateful for the FATHER(Peterknight), John93 and the blynk. problem solved.

Thank you father, you are very great. May you live long.

problem solved…

1 Like