NANO with ESP8266-01 cloud server issue


It’s been a while I’m trying to overcome a problem without success so far.
I’m trying to connect to a cloud server with the ESP8266-01 through NANO using software serial.
For a while it works poorly and very unstable, and now its not working any more.

I know my hardware is good, by testing several non-BLYNK examples of TCP client/server etc. and everything was perfect/

Using DEBUG I receive in my serial monitor the following:

[19] **
** ___ __ __

** / _ )/ /_ _____ / /**
** / _ / / // / _ / '/**
** /
//_, /////_**
** /
/ v0.4.6 on Arduino Nano**

[104] Free RAM: 698
[625] Connecting to YanHad
[3812] AT version: 11 2016 18:09:56)
SDK version:1.5.4(baaeaebb)
Ai-Thinker Technology Co. Ltd.
Jun 13 2016 11:29:20
[11111] +CIFSR:STAIP,""
[11120] Connected to WiFi
[21714] <[02|00|01|00] 5e43a9656853421b814cb3dcd675f017
[33085] <[02|00|01|00] 5e43a9656853421b814cb3dcd675f017

…and so on every 11 sec or so.

As I mentioned, for a while it works and i got in the serial monitor “ready” and “ping[]” messages but only after tens to hundreds connection attempts (11 sec interval).

I tried to change pins, use simpleTimer and a lot of other ideas I found out in this forum and others.

I read about the altsoftwareserial option but I assume it will disable the option to us irsend lib due to occupation of the internal timer.

My sketch is based on the “ESP8266_Shield” built-in example with minor changes.

PLEASE HELP :slight_smile:

We would need to see your modified sketch before we could begin to assist.

Please format it when posting as per these instructions…

#define BLYNK_PRINT Serial   
#include <ESP8266_Lib.h>
#include <BlynkSimpleShieldEsp8266.h>

char auth[] = "5e43a9656853421b814cb3dcd675f017";
char ssid[] = "YanHad";
char pass[] = "XXXXXXXXXX";

#include <SoftwareSerial.h>
SoftwareSerial EspSerial(2, 3); // RX, TX

#define ESP8266_BAUD 9600

ESP8266 wifi(&EspSerial);

void setup()
  // Set console baud rate
  // Set ESP8266 baud rate

  Blynk.begin(auth, wifi, ssid, pass);

void loop()

It seems I solved the problem. I downgrade my BLYNK lib version. The latest one that my sketch still works is 0.4.0.

An explanation will be great if someone knows.