NANO + shield ethernet ENC28J60 supported? [SOLVED]

Hello I’ve some projects that work on NANO + ENC28J60.
Can I still make them work with BLYNK 2.0 ?

I used this library for that :
#include <BlynkSimpleUIPEthernet.h> // ENC28J60 ethernet BLYNK library

Is it still supported by BLYNK 2.0 ?

PS: I ask because I stuck of course :wink:

//minimal code Blynk 2.0

#include <BlynkSimpleUIPEthernet.h> // ENC28J60 ethernet BLYNK library

char auth[] = “blablabla”;

void setup() {

void loop(){;

Detecting libraries used…
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/…
Alternatives for BlynkSimpleUIPEthernet.h: [Blynk@1.0.0]
→ candidates: [Blynk@1.0.0]
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/…
Alternatives for UIPEthernet.h: [UIPEthernet@2.0.6]
→ candidates: [UIPEthernet@2.0.6]
"C:\Program Files (x86)\Arduino\hardware\tools\avr/…
Alternatives for functional: []
→ candidates: []
In file included from C:\Users\ahermant\Google�Drive (\Electronique\ARDUINO\1.SKETCHS IN PROGRESS\libraries\Blynk\src/Blynk/BlynkApi.h:38:0,
from C:\Users\ahermant\Google�Drive (\Electronique\ARDUINO\1.SKETCHS IN PROGRESS\libraries\Blynk\src/BlynkApiArduino.h:14,
from C:\Users\ahermant\Google�Drive (\Electronique\ARDUINO\1.SKETCHS IN PROGRESS\libraries\Blynk\src/Adapters/BlynkEthernet.h:24,
from C:\Users\ahermant\Google�Drive (\Electronique\ARDUINO\1.SKETCHS IN PROGRESS\libraries\Blynk\src/BlynkSimpleUIPEthernet.h:20,
from C:\Users\ahermant\AppData\Local\Temp…
C:\Users\ahermant\Google�Drive (\Electronique\ARDUINO\1.SKETCHS IN PROGRESS\libraries\Blynk\src/Blynk/BlynkConsole.h:20:10: fatal error: functional: No such file or directory
compilation terminated.
Utilisation de la bibliothèque Blynk version 1.0.0 dans le dossier: C:\Users\ahermant\Google Drive ()\Electronique\ARDUINO\1.SKETCHS IN PROGRESS\libraries\Blynk
Utilisation de la bibliothèque UIPEthernet version 2.0.6 dans le dossier: C:\Users\ahermant\Google Drive (\Electronique\ARDUINO\1.SKETCHS IN PROGRESS\libraries\UIPEthernet
exit status 1
Erreur de compilation pour la carte Optiboot on 32-pin cpus

I think it’s related to Blynk 2.0 because I could transmit the sketch to the NANO just before upgrading the Blynk Library from 0.6.1 to 1.0.0.beta3

Where Can I find the right library 1.0.0 (no beta) ?
I tried this one →

but in my IDE when I add .ZIP →
"Specified folder/zip file does not contain a valid library

Please use the library fron the master branch. It will be released soon

1 Like

Fine thank you

Working with →

I recommend the EthernetENC library for enc28j60. You can use it with Ethernet library examples of Blynk. only put `#include <EthernetENC.h>" at the top of the sketch

(I maintain UIPEthernet and EthernetENC)

Thanks for the info.
Is it better than “BlynkSimpleUIPEthernet.h” that works well?
I specially look for the lighter possible solution as NANO has not much memory available.

the settings can reduce flash and memory use:

1 Like