Nano 33 iot can't send floats

Seems the sketch only compiles if a use INT.

If I blynk.virtualwrite a float it doesn’t compile
Arduino: 1.8.13 (Windows 10), Board: “Arduino NANO 33 IoT”

sketch\BlynkTest2.ino.cpp.o: In function `void BlynkApi<BlynkProtocol<BlynkArduinoClientGenarduino::Client > >::virtualWrite(int, float)’:

C:\Users\Toomas\Documents\Arduino\libraries\Blynk\src/Blynk/BlynkParam.h:393: undefined reference to `dtostrf_internal(double, signed char, unsigned char, char*)’

collect2.exe: error: ld returned 1 exit status

exit status 1

Error compiling for board Arduino NANO 33 IoT.

Any idea?

1 Like

@vshymanskyy this seems to be the same issue as reported here…

It seems that some board types don’t support the use of float values in the Blynk.virtualWrite(vPin, value) command.


1 Like

Have you tried using the blynk library, which is one step lower?

Thanks for bringing it to my attention. I’ll re-check it asap

1 Like

We fixed the issue. The timing is perfect - I’m working on a new maintenance release which should be out somewhere next week.
For now, you can download the latest/unreleased library from github master branch:


I can confirm that it works now.
Tanks a lot