My esp8266 no connect with wifi

Hi, i have a problem with my esp8266, i used the example of the led with blynk but no me connect with my red wifi.

We need to see your code, correctly formatted with triple backticks at the beginning and end of your code.
Triple backticks look like this:

Also, which type of ESP8266 dev board are you using?


The type of board is ESP8266 E-12

#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "here I put the code that I get to the email";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "89158604";
char pass[] = "A15FCC6EC4577";

WidgetLED led1(V1);

BlynkTimer timer;

// V1 LED Widget is blinking
void blinkLedWidget()
  if (led1.getValue()) {;
    Serial.println("LED on V1: off");
  } else {
    Serial.println("LED on V1: on");

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "", 80);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8080);

  timer.setInterval(1000L, blinkLedWidget);

void loop()

Is that just an ESP-12E chip on some sort of adapter board, or is it a NodeMCU type of dev board?

If it’s a NodeMCU then the native baud rate is probably 74880 or 115200.

Change your serial monitor to 74880 first and reboot the board. This should show you some boot data in readable format. If not then try changing the serial monitor to 115200.

Once you’ve found the baud rate that your board is using to publish its system messages then change this line of code:

to use the same baud rate. This way, you won’t get the unreadable characters at the beginning of each line.

Next, in the Arduino IDE, go to Tools and change the Debug Port setting from Disabled to Serial and change the Debug Level from None to WIFI.

Re-upload your modified code with these settings and re-start the serial monitor. Set the serial monitor to the baud rate that you used above, clear the output then reboot the board.

If you cant see what the problem is from this data then copy and paste it here (don’t post a screenshot, use CTRL-A to select and CTRL-C to copy the contents of the serial monitor then post it with triple backticks at the beginning and end, just like you did with the code).

If you aren’t using a NodeMCU but have instead simply purchased an ESP-12E chip and built your own circuitry around it then I’d say that’s the first place to start looking for the cause of your problem.


i use a NodeMCU, i changed the baud rate a 115000 and the options of tools.

This appears to me in the monitor serial.

no 89158604 found, reconnect after 1s
wifi evt: 1
STA disconnect: 201
no 89158604 found, reconnect after 1s
wifi evt: 1
STA disconnect: 201

That means it can’t find a WiFi network with the SSID of “89158604”

If this is the correct SSID for your 2.4GHz WiFi network then either your device is out of range of the router, or it’s probably faulty.


I have tried with different ones and I have the same problem.

Different devices, or different SSIDs?

Is your router set up to have different SSIDs for the 2.4 and 5 GHz bands?


Different devices, my router work in 2.4 GHz

Are you 100% certain that the SSID is typed correctly?

Have you tried rebooting your router?


Yes the SSID is typed correctly and yes i rebooted the router