Mkr nb1500 not coming online


I am trying to run the example sketch for the arduino mrk nb1500. I can not seem to get the board to connect online… when I use the

NB nbAccess(true);

to try to debug the serial monitor prints out:

+CEREG: 0,5

[8515] Connecting to …


+CGACT: 1,1

[10040] Connected to GPRS
[10041] Connecting to



when I then check my blynk account the device is “offline”

does anyone have any experience getting this board to communicate and function?

the sim card being used is hologram.

I am fairly new to all of this and don’t understand all of the AT commands but I think I get the jist of it…

much appreciated.

thanks” is the old Blynk server. The new Blynk server is “”.

Have you followed the instructions in the sketch and added your BLYNK_TEMPLATE_ID (and un-commented the second line of code in the process…)

/* Fill-in your Template ID (only if using Blynk.Cloud) */
//#define BLYNK_TEMPLATE_ID “YourTemplateID”



As I am just using example sketch what do I change to get it to connect to “”

Hey Peter,

Yes, I uncomment and pasted my templateID…

Any other clues??


ok, I have tried again new code and token. It is printing out the now

here is what the serial monitor is printing out at the end:


+UUSORD: 0,23

+USORD: 0,23,“29000100126E79332E626C796E6B2E636C6F7564003830”
[11120] Redirecting to


the blynk dashboad says that I am still “offline”

any guidance would be appreceated.

the only thing I modified from the example sketch is the token, device id and added device name…


These AT commands are how the board communicates with the GSM modem. It seems that the board is using the primary COM port for this communication, and you are also trying to debug the Blynk connection via the same port. This results in nonsense data in your serial monitor, but it also results in your GSM modem seeing commands that it doesn’t understand, like “[10040] Connected to GPRS”.

You need to remove the #define BLYNK_PRINT Serial line of code from your sketch, and any additional lines of debug code that you might have added.

For more info about serial communication of this type, and how you can debug via a different COM port or software COM port you should read this…


Hey Pete,

Thanks for the consistent support on helping me resolve this… and thank you for the article to read.

I am still not able to connect the MKR NB to the blynk cloud… I will say it did work for just a moment and at the same time I was trying to get it to also connect to the arduino iot cloud. Arduino said I needed to update the uBlox firmware, which I did and now the board connects every time to the arduino cloud but I am not able to establish any connection to the blynk cloud…

I am using the “Arduino_MKRNB” example from the blynk library. I have commented out
//#define BLYNK_PRINT Serial and have not changed the code at all except to enter in
#define BLYNK_TEMPLATE_ID "YourTemplateID"
char auth[] = "YourAuthToken";

these all match what is on the Blynk web page… There are no other functions add or anything. Always wanting to start as simple as possible

The firmware update is now:
Manufacturer: u-blox
Model: SARA-R410M-02B
Revision: L0. [Apr 17 2019 19:34:02]

If you have any other suggestions or ideas I would really appreciate it!


No ideas I’m afraid. I’m not familiar with your hardware, or what you’re trying to achieve by connecting to Arduino cloud.

I tend to use more mainstream hardware like the ESP8266 and ESP32


Thanks for the reply back.

I am using the arduino MKR NB 1500 which uses LTE’s Cat M1/NB. I like the idea of connecting via a sim and modem and not having to be linked to wifi. I am a mechanical engineering student at the University of Utah and am wanting to use this on some projects. I have built a GPS alarm tracker for a motorcycle using a sim7000a. I am wanting to do something similar with this board amd use blynks app interface to do a little more with it. Possibly send an sms to wake the module up and then use the app interface to see its location and things like start the bike or flip a relay so the bike to kill the ignition.

Basically have fun but with a totally wireless iot device…

As far as the arduino cloud I was just testing to if it would connect to anything…

Speaking of esp32, I have already built a contraption with the bkynk iot and I loved how straight forward the whole process was.

If anything comes to mind please let me know.



One last ditch attempt here… I uncomment the blynk print, just to see what it would do. I am getting
[8514] connecting to …
[10038] connected to GPRS
[10038] connected to
[11835] redirecting to

Does this mean anything?

Anyone else have any ideas? Surley I can not be the only person trying to use this board with bkynk…


Blynk has multiple cloud servers around the globe.
Your account and its associated templates, devices and data only exist on one of these.
You can see which one in the bottom right of your web console, or in the about screen of the app.
In your case it will be the New York server known as ny3.

Your mobile data ISP’s DNS service is presumably resolving to a different geographic cloud server, then that is re-directing to the correct server.

If you want to ensure that this doesn’t happen then you can full server url, including the regional subdomain, in your connection command.

If you’re using Blynk.begin then you’ll specify “” as the server url.

But, without this it should redirect okay and the device should appear online.


Hey Pete!

putting in that address at the end of Blynk.begin function worked! I guess it was getting hung up trying to redirect!

thanks for your help! I really appreciate it!

1 Like