Migration to Blynk 2.0 on ESP8266 Board with Infrared IR sketch

I’m late to the B2.0 upgrade party; I waited for @MariiaDrozhak to announce Dark mode for the Web Portal and for the Arduino libraries to go thru at least one iteration process of debugging. I’m up & running now. Christmas came early.
I compiled the Web Portal Quickstart Device demo for my Wemos D1 ESP8266 WiFi board; it works. My question is this; the template status is shown offline, but the App is alive and running. See pics. Did I just rediscover a known bug? Thanks.

Not really. Do you see the same on the web (device status)? There is high chance device is disconnected eight after it connected.

The App uptime value is incrementing when the Wemos device is plugged in; when I unplug the device the uptime value stops incrementing, and eventually I get a message as expected from the Blynk App that the device has disconnected. Performance is not consistent; I’ll keep testing to see if I can create a list of steps to make it always fail. The attached screen-shot you requested is from the Web Portal. The Button Control and Switch Value icons do not change, and the Uptime Value (301,501) does not match what is shown on my iPhone App (558) right now. If I unplug the device, about a minute later I get a disconnect shown on my iPhone screen. It’s still running because I haven’t seen any disconnect yet.

You are aware this screenshot is from the TEMPLATE design and not the DEVICE?

Press the search icon (magnifying glass) and locate your device.

Thanks, corrected. This (active) screenshot now matches the iPhone App and the Uptime values match. The App status on my iPhone still shows as offline even though the App is running on the iPhone and shown online on the Web…
2021-10-16_10-54-47 Quick Template2 on Web

Ignoring the Online/Offline indicators for now, I proceeded to port my Arduino Remote Control emulation to B2. The template creation was successful; it goes online and button presses for all 20 functions transmit from the App to the Blynk Cloud and down to the Wemos D1 ESP8266 device. It is shown in its blue acrylic case with a Keystone IR emitter LED plugged in. This worked great on the original Blynk, but no IR signals are being sent out the LED to whatever device is to be controlled now. I updated the IRremoteESP8266 library originally used on Blynk 0.1 (2.7.15) to the latest 2.7.20 for Blynk 2.0, but that did not solve the problem. I will continue investigation and testing.

Hey there,

Have you tried this library :

I’m 100% sure it’s working with blynk 2.0.

Thanks, I’ll check it out sometime this week. I have always used the ESP8266 version because that is what the Wemos D1 worked fine with on the original Blynk. Might be time to switch if it works.

I wish you good luck.
Have a great day.

1 Like

Hi Mike, are you using the Edgent sketch, or have you just added the template ID etc to the top of your old sketch?


Hey Pete !! I just created the template from scratch in the new Blynk on my iPhone. It works great when paired with the Wemos ESP8266 device on the Web Portal. Getting IR processing to work is one of the last steps.

But sketch are you running on the Wemos?


The Wemos sketch is the original sketch running on the classic Blynk with the new #define’s for TEMPLATE_ID and DEVICE_NAME added. All 20 buttons on the new B2.0 template work.

1 Like

@John93 Commenting out my #include for IRremoteESP8266.h and replacing it with an #include for IRremote.h (version 3.4.0) gives me a compile error for the Wemos D1 board I’m using. Compiles clean for the ESP8266 version. Exact message:

exit status 1
Error compiling for board LOLIN(WEMOS) D1 R2 & mini.

The GitHub documentation does not list the WEMOS D1 as a supported board, only an ESP8266 fork that supports an impressive set of protocols and a lot of air conditioners
I’ll keep testing on the ESP8266 library code …

Update 10/19 - Tried my Adafruit Huzzah and NodeMCU ESP8266 just to eliminate any hardware problems; same result as with the Wemos D1. No IR signals going out on GPIO4. Still testing …

@Dmitriy Update - Startup/Shutdown testing. Things seem to have stabilized on either my end or the Blynk Cloud end. I’m getting correct notification when the ESP8266 device is up or down now. Here are pics of the four phases; offline, online, time-out, and offline. I’m still working to get the new Blynk 2.0 / ESP8266 libraries working with Infrared. They work well on the original “classic” Blynk but not on 2.0.

Hey buddy, I’m using esp32 and IRremote library and everything is working just fine. Have you tried the esp32 ?

No, I don’t have any ESP32’s, just all the different ESP8266 boards listed above. Maybe I’ll pick one up just to give it a try. My project uses the Wemos D1 (Arduino) form-factor, so ultimately I have to get everything working on that. My Wemos boards have 12E and latest 12F level WiFi chips on them. Which ESP32 board are you using? Are you doing both IR sending and IR receiving?

Currently I’m using receiving, but I will try sending and I will let you know if I face any issue.

1 Like

I’m using esp32 wroom, both sending and receiving works fine.

OK, I’ll go order one.
Are you using these same #inclide libraries as me?
// Sketch definitions to run in ESP8266:
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>
#include <IRremoteESP8266.h>
#include <IRsend.h>