BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Making a personal server on a WD cloud NAS drive (or PC), how do I do it?

esp8266

#1

Hi everyone,

I have a WDMyCloudEX2 NAS drive, I would like to send data from an arduino uno + ESP8266MOD to a personal server on the NAS drive that I can then read on the Blynk app, is this even possible?

I have been reading on how to install a personal server but I can’t make sense of it eg. the instructions on GitHub:

Run the server on default ‘hardware port 8080’ and default ‘application port 9443’ (SSL port)

  java -jar server-0.41.0.jar -dataFolder /path

I’m assuming this is what I type into the CMD prompt? but I’m not 100% sure, help would be greatly appreciated and I understand I’m kinda trying to run before I can walk by trying to add a personal server to a NAS drive!


#2

Based on a quick peek at your NAS specs, I do not see any Linux environment Java support option… I think you should stick with a Raspberry Pi option, or any old PC/laptop running bare Linux will do.

If you are not familiar with any basic Linux then I highly recommend starting learning Blynk using Blynk’s Cloud Server first.


#3

Ok thanks, thought it would have been the case, but can’t hurt to ask! the RPi option looks interesting may give that a go at some point, I’ll try setting up a server on my pc first and get used to that


#4

Ok so I tried following Sid’s E Classroom on installing a server got to the bit where you type in CMDprompt:
java -jar server-0.41.0 -dataFolder /Path and it said
Error: Unable to access jarfile server-041.0
any ideas?


#5

don’t you need to change the /Path to your own actual /Path?


#6

Still comes back with the same :slightly_frowning_face:


#7

If the NAS is Linux based, maybe permission problems?


#8

Im just trying on my pc instead but still no luck


#9

Tried installing local server on both my mac and pc using the latest 0.41.0 and both failed in exactly the same way saying it could not read the jar file, is there a bug with the new version or am I doing something wrong?


#10

Without seeing exact errors… Bad file download?? Not properly installed?

Not a clue with so little to go on.

But no bug as I am using the same version without issue.


#11

My apologies, here’s all I’ve got:
Running windows 7 64 bit
C:\Users\Ollie>java -version
java version “1.8.0_191”
Java™ SE Runtime Environment (build 1.8.0_191-b12)
Java HotSpot™ 64-Bit Server VM (build 25.191-b12, mixed mode)

I have
Java SE Development Kit 8 Update 191 (64-bit)
Java™ SE Development kit 9.0.1 (64-bit)
installed,

I created a folder for the server in my documents downloaded the server file from Github labeled server-0.41.0.jar (17.3MB) and put it into the folder.

I’ve done exactly as in this > https://www.youtube.com/watch?v=XJNzjH-bYsA&t=604s <video up to 7:55

then I got this in CMDprompt running as administrator

Microsoft Windows [Version 6.1.7601]
Copyright © 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd C:\Users\Ollie\Documents\Blynk PERSONAL SERVER

C:\Users\Ollie\Documents\Blynk PERSONAL SERVER>java -jar server-0.41.0.jar -data
Folder /Path
Error: Unable to access jarfile server-0.41.0.jar

I also tried changing “/path” to /location of that folder copied from windows explorer bar but had the exact same result


#12

OK, I merged your topics as they are really all about the same thing… issues installing Local Server.

That video was so two years ago :stuck_out_tongue:

Try using the more current and official directions… And i think the type of Java you install may be part of the issue…

Java 8/10 (OpenJDK, Oracle) is required. It has been a while since I needed to install Local Server, and Oracle gets very persnickety about how you get their stuff, thus the link in the directions is not working… however the JDK is what you need. But version 10 seems MIA and I don’t know if their latest version 11 will work?? @Dmitriy


#13

could you point me to said “official directions”? as all I see on git hub is putting in 1 line to the CMDprompt and bobs your uncle it should work

do I need to download all of the files in the Assets section and if so what do I do with them? I feel like im missing something as is sounds so simple :upside_down_face:

I downloaded the most recent java files from their website or do I need an older version?


#14

Umm… you mean the big link in my last post :wink: I ran a search and no word “Bob” anywhere in there :smile:

But yes, Once java is installed (I installed dk-8u192-windows-x64.exe) I created a Blynk folder off of my C:\ copied the latest Blynk server file to it and ran it in a Command prompt window like such… You do have to account for the actual file name you downloaded and the actual path for your data folder, but that is generally a given assumption…

image

And of course if you close the window, the server will stop running (there are ways… read the Enabling server auto restart on Windows part of that document). But even if you leave it open, you still need to setup other advanced settings for certifications and email… That is where all the rest of the reading of that document comes into play.


#15

Ok now I feel silly :joy: I’ll give that a try again maybe it was because I downloaded the server-0.41.0.jar instead of server-0.41.0-java8.jar?

thanks for your patience!


#16

The non java8 file is for the newer java versions… I just stick with java8 as it is a known working setup… and I don’t like unnecessary change :stuck_out_tongue:


#17

Ok that worked first time, using the wrong file :upside_down_face: thanks for your help!


#18

How do I change my default admin password & name? is it in the server files or on the admin page?


#19

All the info is in the GitHub page - https://github.com/blynkkk/blynk-server#advanced-local-server-setup

image


#20

ok so all was working fine and when setting up the library this time on my mac running 10.13.6 I put in terminal java -jar-0.41.0-java8.jar -dataFolder data_server & and it all worked but I restarted my laptop to check the server started again and it didn’t, I tried the crontab -e but it comes up with “/tmp/crontab.UDXoHrnUtK” 0L, 0C